Project

Profile

Help

Issue #4857

Pulp 2 Nightly Regression in test_iso_crud.ISOUpdateTestCase.test_all

Added by bherring 5 months ago. Updated 5 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
Yes
Sprint:
Sprint 53

Description

Problem Summary

Testing of *test_iso_crud` in nightly CI in 2-master since May 16, 2019.

Please see the test in Pulp-2-Tests for a good description of the test.

Using pulp-smash shell or running the test through pulp-smash and verifying the failure through journalctl is the easiest way to recreate for this test type.

This test is long-standing.

Test Synopsis

Do the following:
1. Create and sync an ISO repository.
2. Update the repository's feed URL, and sync it. This simulates a change in the contents of the source ISOs.
3. Assert that number of units remain the same, but the content has changed.

Command Failure

Changing the import to the second file feed and then syncing causes the task error:

        # Step 2
        client.put(repo['importers'][0]['_href'], {
            'importer_config': {'feed': FILE2_FEED_URL}
        })
        sync_repo(cfg, repo)

journalctl of task failure

May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.plugins.file.distributor:ERROR: [b91bfe80] (20384-05632) [(u'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/3.iso', u'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/3.iso', '[Errno 17] File exists'), (u'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/1.iso', u'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/1.iso', '[Errno 17] File exists'), (u'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/2.iso', u'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/2.iso', '[Errno 17] File exists')]
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.plugins.file.distributor:ERROR: [b91bfe80] (20384-05632) Traceback (most recent call last):
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.plugins.file.distributor:ERROR: [b91bfe80] (20384-05632)   File "/usr/lib/python2.7/site-packages/pulp/plugins/file/distributor.py", line 189, in publish_repo_fast_forward
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.plugins.file.distributor:ERROR: [b91bfe80] (20384-05632)     copytree(build_dir, location, symlinks=True)
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.plugins.file.distributor:ERROR: [b91bfe80] (20384-05632)   File "/usr/lib/python2.7/site-packages/pulp/server/util.py", line 287, in copytree
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.plugins.file.distributor:ERROR: [b91bfe80] (20384-05632)     raise Error(errors)
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.plugins.file.distributor:ERROR: [b91bfe80] (20384-05632) Error: [(u'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/3.iso', u'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/3.iso', '[Errno 17] File exists'), (u'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/1.iso', u'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/1.iso', '[Errno 17] File exists'), (u'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/2.iso', u'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/2.iso', '[Errno 17] File exists')]
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.server.controllers.repository:INFO: [b91bfe80] {'state': 'failed', 'error_message': "[(u'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/3.iso', u'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/3.iso', '[Errno 17] File exists'), (u'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/1.iso', u'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/1.iso', '[Errno 17] File exists'), (u'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/2.iso', u'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/2.iso', '[Errno 17] File exists')]", 'traceback': 'Traceback (most recent call last):\n  File "/usr/lib/python2.7/site-packages/pulp/plugins/file/distributor.py", line 189, in publish_repo_fast_forward\n    copytree(build_dir, location, symlinks=True)\n  File "/usr/lib/python2.7/site-packages/pulp/server/util.py", line 287, in copytree\n    raise Error(errors)\nError: [(u\'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/3.iso\', u\'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/3.iso\', \'[Errno 17] File exists\'), (u\'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/1.iso\', u\'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/1.iso\', \'[Errno 17] File exists\'), (u\'/var/cache/pulp/reserved_resource_worker-0@rhel76-nightly/b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6/build/2.iso\', u\'/var/lib/pulp/published/https/isos/870fe7fa-dae5-49b2-ad00-ca19f7075fc7/2.iso\', \'[Errno 17] File exists\')]\n', 'state_times': {'failed': '2019-05-21T12:13:35', 'not_started': '2019-05-21T12:13:35', 'in_progress': '2019-05-21T12:13:35'}}
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.server.controllers.repository:ERROR: [b91bfe80] (20384-05632) Exception caught from plugin during publish for repo [870fe7fa-dae5-49b2-ad00-ca19f7075fc7]
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.server.controllers.repository:ERROR: [b91bfe80] (20384-05632) Traceback (most recent call last):
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.server.controllers.repository:ERROR: [b91bfe80] (20384-05632)   File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 1265, in _do_publish
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.server.controllers.repository:ERROR: [b91bfe80] (20384-05632)     distributor_id=dist_id, summary=publish_report.summary
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.server.controllers.repository:ERROR: [b91bfe80] (20384-05632) PulpCodedException: The distributor iso_distributor indicated a failed response when publishing repository 870fe7fa-dae5-49b2-ad00-ca19f7075fc7.
May 21 08:13:35 rhel76-nightly pulp[20384]: pulp.server.async.tasks:INFO: [b91bfe80] Task failed : [b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6] : The distributor iso_distributor indicated a failed response when publishing repository 870fe7fa-dae5-49b2-ad00-ca19f7075fc7.
May 21 08:13:35 rhel76-nightly pulp[20384]: celery.app.trace:INFO: [b91bfe80] Task pulp.server.managers.repo.publish.publish[b91bfe80-69fd-4fef-bd96-c5dc4f9f1ec6] raised expected: PulpCodedException()
May 21 08:13:35 rhel76-nightly pulp[20384]: celery.app.trace:INFO: [80f9f51e] Task pulp.server.async.tasks._release_resource[80f9f51e-bae6-434f-834c-1c9ffde941d6] succeeded in 0.00546025601216s: None

Additional Information


Related issues

Related to Pulp - Issue #4780: Task search by invalid field should raise meaningful error POST Actions
Related to Pulp - Story #4708: Improve performance of publishing files with iso_distributor via the way of fast-forward CLOSED - CURRENTRELEASE Actions
Duplicates Pulp - Issue #4865: PULP_MANIFEST does not update correctly to publish files with iso_distributor via fast-forward when deleting an unit CLOSED - CURRENTRELEASE Actions

History

#1 Updated by bherring 5 months ago

  • Project changed from RPM Support to File Support

#2 Updated by bherring 5 months ago

  • Description updated (diff)

#3 Updated by ttereshc 5 months ago

  • Project changed from File Support to RPM Support

#4 Updated by bherring 5 months ago

  • Related to Issue #4856: Uploading ISOs of same name to a repo creates duplicates, makes repo unusable added

#5 Updated by rmcgover 5 months ago

I think this is probably caused by https://pulp.plan.io/issues/4708 and related changes, and issue https://pulp.plan.io/issues/4856 being filed around the same time is just a coincidence.

Specifically, commit d60bd2eaf581dec67d03b46467bb11cae50c3cd0 enabled a new code path for ISO publish and that was merged on May 15.

#6 Updated by bherring 5 months ago

  • Related to Issue #4780: Task search by invalid field should raise meaningful error added

#7 Updated by ttereshc 5 months ago

  • Related to Story #4708: Improve performance of publishing files with iso_distributor via the way of fast-forward added

#8 Updated by ttereshc 5 months ago

  • Related to deleted (Issue #4856: Uploading ISOs of same name to a repo creates duplicates, makes repo unusable)

#9 Updated by ttereshc 5 months ago

Issue is reproducible and valid and was introduced by this commit. The test itself is fine, imo, and should not be modified.
This PR fixes the issue.

#10 Updated by ttereshc 5 months ago

  • Related to Issue #4856: Uploading ISOs of same name to a repo creates duplicates, makes repo unusable added

#11 Updated by ttereshc 5 months ago

  • Status changed from NEW to POST
  • Triaged changed from No to Yes
  • Sprint set to Sprint 53

#12 Updated by ttereshc 5 months ago

  • Related to deleted (Issue #4856: Uploading ISOs of same name to a repo creates duplicates, makes repo unusable)

#13 Updated by ttereshc 5 months ago

Closing this as a dupe in favor of contributor's issue.

#14 Updated by ttereshc 5 months ago

  • Status changed from POST to CLOSED - DUPLICATE

#15 Updated by ttereshc 5 months ago

  • Duplicates Issue #4865: PULP_MANIFEST does not update correctly to publish files with iso_distributor via fast-forward when deleting an unit added

Please register to edit this issue

Also available in: Atom PDF