Project

Profile

Help

Issue #4792

Serialization bug on Publications

Added by dalley over 1 year ago. Updated about 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

See "repository"

(pulp) [vagrant@pulp3-source-fedora29 pulpcore]$ http :24817/pulp/api/v3/publications/rpm/rpm/
HTTP/1.1 200 OK
Allow: GET, POST, HEAD, OPTIONS
Connection: close
Content-Length: 417
Content-Type: application/json
Date: Tue, 07 May 2019 18:32:02 GMT
Server: gunicorn/19.9.0
Vary: Accept, Cookie
X-Frame-Options: SAMEORIGIN

{
    "count": 1,
    "next": null,
    "previous": null,
    "results": [
        {
            "_created": "2019-05-07T18:31:26.741760Z",
            "_distributions": [],
            "_href": "/pulp/api/v3/publications/rpm/rpm/cf5260ab-bc6e-4f70-b91a-0a43ab19d83f/",
            "_type": "rpm.rpm",
            "publisher": null,
            "repository": "http://localhost:24817/pulp/api/v3/repositories/%3CRepository:%20foo%3E/",
            "repository_version": "/pulp/api/v3/repositories/b8a3180f-e801-48f1-b124-a2087322bbe7/versions/1/"
        }
    ]
}

Related issues

Is duplicate of Pulp - Issue #4749: "repository" field on Publication is brokenCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

Associated revisions

Revision 60dac54d View on GitHub
Added by dalley over 1 year ago

Fix serialization of repository field on Publications

closes #4792 https://pulp.plan.io/issues/4792

History

#1 Updated by dalley over 1 year ago

  • Project changed from RPM Support to Pulp

#2 Updated by dalley over 1 year ago

  • Status changed from NEW to ASSIGNED

#3 Updated by ipanova@redhat.com over 1 year ago

  • Assignee set to dalley

#4 Updated by amacdona@redhat.com over 1 year ago

  • Triaged changed from No to Yes

#5 Updated by dalley over 1 year ago

  • Status changed from ASSIGNED to POST

#6 Updated by kersom over 1 year ago

  • Related to Issue #4749: "repository" field on Publication is broken added

#7 Updated by dalley over 1 year ago

  • Related to deleted (Issue #4749: "repository" field on Publication is broken)

#8 Updated by dalley over 1 year ago

  • Is duplicate of Issue #4749: "repository" field on Publication is broken added

#9 Updated by dalley over 1 year ago

  • Status changed from POST to CLOSED - DUPLICATE

I ran across this separately and didn't see this issue, so I filed a new one. The underlying issue will be fixed with https://github.com/pulp/pulpcore/pull/152

#10 Updated by dalley over 1 year ago

  • Status changed from CLOSED - DUPLICATE to POST

#11 Updated by dalley over 1 year ago

  • Status changed from POST to MODIFIED

#12 Updated by bmbouter about 1 year ago

  • Sprint/Milestone set to 3.0.0

#13 Updated by bmbouter about 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF