Project

Profile

Help

Story #4651

closed

As a user, I can install pulp 3 on a RHEL host

Added by kersom about 5 years ago. Updated almost 4 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
-
Start date:
Due date:
% Done:

100%

Estimated time:
(Total: 0:00 h)
Platform Release:
Groomed:
Yes
Sprint Candidate:
No
Tags:
Sprint:
Sprint 60
Quarter:

Description

As a user, I can install pulp 3 on a RHEL host using the Ansible installer.

The scope of this story is limited to using the ansible installer against a RHEL machine with the subscription already enabled.

This story does not include testing/CI. Covered here (https://pulp.plan.io/issues/4659)


Sub-issues 2 (0 open2 closed)

Task #5557: Add ansible-pulp logic to add the RHEL7 optional repoCLOSED - CURRENTRELEASEmdepaulo@redhat.com

Actions
Task #5558: Add ansible-pulp logic to grab epel-release from the internetCLOSED - CURRENTRELEASEmdepaulo@redhat.com

Actions

Related issues

Related to RPM Support - Issue #5496: installer fails on el7 installing pulp_rpmCLOSED - CURRENTRELEASEmdepaulo@redhat.comActions
Blocks Pulp - Test #4659: Add RHEL to the ansible-pulp molecule CICLOSED - DUPLICATEActions
Actions #1

Updated by amacdona@redhat.com about 5 years ago

  • Tracker changed from Issue to Story
  • % Done set to 0
Actions #2

Updated by bmbouter about 5 years ago

Since the installer works on CentOS I imagine it already works on RHEL. If the installer doesn't work for some reason that would be good to fix.

Since I believe it works I read this not as a Story but as a Test activity. Also how will we assure this stays working over time?

Actions #3

Updated by amacdona@redhat.com about 5 years ago

This isn't just a test activity. New OS vars files will be created in the ansible-pulp repo for RHEL that will be necessary even if installing by hand.

Actions #4

Updated by amacdona@redhat.com about 5 years ago

  • Description updated (diff)
Actions #5

Updated by amacdona@redhat.com about 5 years ago

  • Blocks Test #4659: Add RHEL to the ansible-pulp molecule CI added
Actions #6

Updated by bmbouter about 5 years ago

This rewrite looks good to me. Thanks!

Actions #7

Updated by bmbouter almost 5 years ago

  • Tags deleted (Pulp 3)
Actions #8

Updated by kersom over 4 years ago

I attempted to use the installer to install Pulp 3 on RHEL7.6 subscribed box.

TASK [pulp : Load OS specific variables] *****************************************************************************
fatal: [192.168.122.7]: FAILED! => changed=false 
  ansible_facts: {}
  ansible_included_var_files: []
  message: |-
    Could not find or access 'RedHat.yml'
    Searched in:
            /tmp/tmp.1eoSX7RspC/ansible-pulp/roles/pulp/vars/RedHat.yml
            /tmp/tmp.1eoSX7RspC/ansible-pulp/roles/pulp/RedHat.yml
            /tmp/tmp.1eoSX7RspC/ansible-pulp/roles/pulp-database/vars/RedHat.yml
            /tmp/tmp.1eoSX7RspC/ansible-pulp/roles/pulp-database/RedHat.yml
            /tmp/tmp.1eoSX7RspC/ansible-pulp/roles/pulp/tasks/vars/RedHat.yml
            /tmp/tmp.1eoSX7RspC/ansible-pulp/roles/pulp/tasks/RedHat.yml
            /tmp/tmp.1eoSX7RspC/vars/RedHat.yml
            /tmp/tmp.1eoSX7RspC/RedHat.yml on the Ansible Controller.
    If you are using a module and expect the file to exist on the remote, see the remote_src option

PLAY RECAP ***********************************************************************************************************
192.168.122.7              : ok=5    changed=0    unreachable=0    failed=1   

Same playbook was used to install Pulp 3 on a CentOS7 box.

Actions #9

Updated by mdepaulo@redhat.com over 4 years ago

  • Groomed changed from No to Yes
  • Sprint set to Sprint 57
Actions #10

Updated by mdepaulo@redhat.com over 4 years ago

Some tips:

1. Until we have a need for them to differ, RedHat.yml should be a symlink to CentOS.yml .
2. You'll have to use different logic to add epel, because epel-release is not in RHEL.

Actions #11

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 57 to Sprint 58
Actions #12

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 58 to Sprint 59
Actions #13

Updated by rchan over 4 years ago

  • Assignee set to mdepaulo@redhat.com
Actions #14

Updated by rchan over 4 years ago

For the RPM plugin, we will need createrepo_c 0.13.0+ , the most important functionality which we need there is a modular errata support. The motivation for this issue is to allow testing of the migration tool. We don't want to block testing of the tool for content types that are ready, so we can create a separate issue to handle RPM if necessary.

Actions #15

Updated by daviddavis over 4 years ago

  • Status changed from NEW to ASSIGNED
Actions #16

Updated by mdepaulo@redhat.com over 4 years ago

rchan wrote:

For the RPM plugin, we will need createrepo_c 0.13.0+ , the most important functionality which we need there is a modular errata support. The motivation for this issue is to allow testing of the migration tool. We don't want to block testing of the tool for content types that are ready, so we can create a separate issue to handle RPM if necessary.

1. As we discussed on IRC, for RHEL7 they do not build the python3-createrepo_c subpackage of "createrepo_c". This is a packaging change for the overall "createrepo_c" source RPM.

2. RHEL8 & 8.1 beta have python3-createrepo_c, but only at 0.11.0-1 . So we need the the overall createrepo_c package upgraded on RHEL8 as well.

Actions #17

Updated by mdepaulo@redhat.com over 4 years ago

  • % Done changed from 0 to 70

As part of https://pulp.plan.io/issues/5496 , we managed to install the Pulp-maintained PyPI-hosted createrepo_c, and thus pulp_rpm, on CentOS 7.7 .

I will make 1 more change (add a variable for the RHEL7 extras repo, which will default to "rhel-7-server-extras-rpms" but can be set to blank or another value) for this PR.

Actions #18

Updated by rchan over 4 years ago

  • Sprint changed from Sprint 59 to Sprint 60
Actions #19

Updated by kersom over 4 years ago

  • Related to Issue #5496: installer fails on el7 installing pulp_rpm added
Actions #20

Updated by mdepaulo@redhat.com over 4 years ago

I realized that the only RHEL repo we need to enable now is actually optional, not extras, since we are not trying to get libmodulemd from RHEL.

There are several common names for that repo, and many possible ones if managed by Katello/Satellite or other custom repo management.

I am working on enabling a list of several common names; the 1st one found only. It is more complex than you'd expect (yum-config-manager is easy to make idempotent.) It also lets users specify a list, or a specific name, instead.
https://github.com/pulp/ansible-pulp/pull/172

Other remaining work:

  • Symlink/check CentOS vars yml files as RedHat ones.
  • Similar list logic for "epel-release" vs the epel URL (the URL is equivalent to a package name)

Added by Mike DePaulo over 4 years ago

Revision d65ab89b | View on GitHub

Add CentOS -> RedHat vars symlinks

Fixes: #4651 As a user, I can install pulp 3 on a RHEL host https://pulp.plan.io/issues/4651

Actions #21

Updated by Anonymous over 4 years ago

  • Status changed from ASSIGNED to MODIFIED

Added by Mike DePaulo over 4 years ago

Revision 01f740bd | View on GitHub

Add CentOS -> RedHat vars symlinks

Fixes: #4651 As a user, I can install pulp 3 on a RHEL host https://pulp.plan.io/issues/4651

Added by Mike DePaulo over 4 years ago

Revision 391802c4 | View on GitHub

Add CentOS -> RedHat vars symlinks

Fixes: #4651 As a user, I can install pulp 3 on a RHEL host https://pulp.plan.io/issues/4651

Added by Mike DePaulo over 4 years ago

Revision 391802c4 | View on GitHub

Add CentOS -> RedHat vars symlinks

Fixes: #4651 As a user, I can install pulp 3 on a RHEL host https://pulp.plan.io/issues/4651

Actions #22

Updated by mdepaulo@redhat.com over 4 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

This was merged a while ago. Any reported issues were resolved. so I'm marking as closed.

Actions #23

Updated by bmbouter almost 4 years ago

  • Category set to Installer - Moved to GitHub issues
  • Tags deleted (Pulp 3 installer)

Also available in: Atom PDF