Project

Profile

Help

Task #4556

Change Pulp 3 Default Ports

Added by mdepaulo@redhat.com 7 months ago. Updated 5 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Platform Release:
Blocks Release:
Backwards Incompatible:
No
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:
Sprint 52

Description

For most Pulp 3 installations, it seems there are two default applications that will be running: API and content. Those applications are currently set to run on 8000 and 8080 respectively.

The problem is that these are common HTTP auxiliary ports. Lots of other applications use them. If 2 daemons try to listen on the same port, even on localhost only, the daemon started earlier will block the one started later (or the one started later will not listen on the port.)

Scenarios might include:

1. A moderately skilled sysadmin sets up Pulp in a test environment. In the test environment, compliance agents (log collection, anti-virus, etc) are installed with their WebGUIs enabled. One listens on port 8080, and therefore Pulp fails to start. The sysadmin figures this out, but only after debugging why. Eventually, their effort to use Pulp takes too long, and management instructs them to shift to other higher priority / unplanned tasks.

2. A junior sysadmin has about a dozen production servers running a LOB application, and a small server to run supporting services. The supporting services, including Pulp, all must run on that 1 server due to expensive licensed software needing to be installed on every physical or virtual machine. Another important supporting service is on this machine, and listens on port 8000. The junior sysadmin is incapable of figuring out why Pulp doesn't start, and gives up on Pulp

Another reason to change the ports is that it might be more obvious for operators and developers to have the defaults next to each other in order to make it more predictable and easier to remember.

My suggestion is: 24816 (API) and 24817 (content). (Update: now 24816 (content) and 24817 (API))
These are easy to remember for technical people: Powers of 2 are 2, 4, 8, 16.
And they are unallocated to any application.

These default values need to be updated in multiple places, such as documentation.

email thread: https://www.redhat.com/archives/pulp-dev/2019-March/msg00028.html


Subtasks

Task #4594: Update docs for changed Pulp 3 Default PortsCLOSED - COMPLETEmdepaulo@redhat.com

Actions
Task #4595: Update Release Notes for changed Pulp 3 Default PortsCLOSED - COMPLETEmdepaulo@redhat.com

Actions

History

#1 Updated by mdepaulo@redhat.com 7 months ago

  • Description updated (diff)

#2 Updated by mdepaulo@redhat.com 7 months ago

  • Description updated (diff)

#3 Updated by daviddavis 7 months ago

  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes

#4 Updated by mdepaulo@redhat.com 7 months ago

I'm also thinking of switching the ports around, since 24816 is more memorable.

The question is which will users interact with more? Like the port that will be more likely to need to be allowed through a firewall. I would think the content will be.

#5 Updated by bmbouter 7 months ago

I think the reasoning on this is sound. +1 to this story.

I also believe that the content API is probably the "more important" one in that it will serve content to many users and through firewalls versus the Pulp API which will won't be served to as many users and not across as many firewalls.

#6 Updated by dkliban@redhat.com 7 months ago

  • Sprint set to Sprint 51

#7 Updated by mdepaulo@redhat.com 7 months ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to mdepaulo@redhat.com

We agreed during the Sprint 51 planning meeting that the content port will be the most commonly used one. So it will be 24816, and the APi will be 24817.

#8 Updated by mdepaulo@redhat.com 7 months ago

  • Description updated (diff)

#9 Updated by mdepaulo@redhat.com 6 months ago

  • Status changed from ASSIGNED to POST

https://github.com/pulp/pulpcore/pull/75

As well as many other PRs for other Pulp & plugin repos.

#10 Updated by mdepaulo@redhat.com 6 months ago

@rochabruno indicated that he would update pulp-ci for this also.

I am willing to submit a PR myself though (partially to get more familiar with the QE & CI process.)

#11 Updated by rchan 6 months ago

  • Sprint changed from Sprint 51 to Sprint 52

#12 Updated by bmbouter 6 months ago

  • Tags deleted (Pulp 3)

#13 Updated by mdepaulo@redhat.com 6 months ago

  • Status changed from POST to MODIFIED

#14 Updated by mdepaulo@redhat.com 5 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF