Project

Profile

Help

Issue #4502

syncing rhel 6 repo results in error "null value in column \"ref_id\" violates not-null constraint\nDETAIL: Failing row contains (1, https://rhn.redhat.com/errata/RHBA-2013-0387.html, null, RHBA-2013:0387, self, 1)

Added by jsherril@redhat.com over 2 years ago. Updated over 2 years ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 50
Quarter:

Description

        "code": null, 
        "description": "null value in column \"ref_id\" violates not-null constraint\nDETAIL:  Failing row contains (1, https://rhn.redhat.com/errata/RHBA-2013-0387.html, null, RHBA-2013:0387, self, 1).\n", 
        "traceback": "  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/worker.py\", line 799, in perform_job\n    rv = job.perform()\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/job.py\", line 600, in perform\n    self._result = self._execute()\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/rq/job.py\", line 606, in _execute\n    return self.func(*self.args, **self.kwargs)\n  File \"/home/vagrant/nfs/pulp_rpm/pulp_rpm/app/tasks/synchronizing.py\", line 67, in synchronize\n    dv.create()\n  File \"/home/vagrant/devel/pulpcore-plugin/pulpcore/plugin/stages/declarative_version.py\", line 169, in create\n    loop.run_until_complete(pipeline)\n  File \"/usr/lib64/python3.6/asyncio/base_events.py\", line 468, in run_until_complete\n    return future.result()\n  File \"/home/vagrant/devel/pulpcore-plugin/pulpcore/plugin/stages/api.py\", line 209, in create_pipeline\n    await asyncio.gather(*futures)\n  File \"/home/vagrant/devel/pulpcore-plugin/pulpcore/plugin/stages/api.py\", line 43, in __call__\n    await self.run()\n  File \"/home/vagrant/devel/pulpcore-plugin/pulpcore/plugin/stages/content_stages.py\", line 112, in run\n    await self._post_save(batch)\n  File \"/home/vagrant/nfs/pulp_rpm/pulp_rpm/app/tasks/synchronizing.py\", line 366, in _post_save\n    UpdateReference.objects.bulk_create(update_references_to_save)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/db/models/manager.py\", line 82, in manager_method\n    return getattr(self.get_queryset(), name)(*args, **kwargs)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/db/models/query.py\", line 465, in bulk_create\n    ids = self._batched_insert(objs_without_pk, fields, batch_size)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/db/models/query.py\", line 1149, in _batched_insert\n    inserted_id = self._insert(item, fields=fields, using=self.db, return_id=True)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/db/models/query.py\", line 1136, in _insert\n    return query.get_compiler(using=using).execute_sql(return_id)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/db/models/sql/compiler.py\", line 1289, in execute_sql\n    cursor.execute(sql, params)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/db/backends/utils.py\", line 68, in execute\n    return self._execute_with_wrappers(sql, params, many=False, executor=self._execute)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/db/backends/utils.py\", line 77, in _execute_with_wrappers\n    return executor(sql, params, many, context)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/db/backends/utils.py\", line 85, in _execute\n    return self.cursor.execute(sql, params)\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/db/utils.py\", line 89, in __exit__\n    raise dj_exc_value.with_traceback(traceback) from exc_value\n  File \"/usr/local/lib/pulp/lib64/python3.6/site-packages/django/db/backends/utils.py\", line 85, in _execute\n    return self.cursor.execute(sql, params)\n"

History

#1 Updated by ttereshc over 2 years ago

  • Description updated (diff)

Pre'd the description

#2 Updated by ttereshc over 2 years ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 49
  • Tags Pulp 3 added

#3 Updated by rchan over 2 years ago

  • Sprint changed from Sprint 49 to Sprint 50

#4 Updated by ttereshc over 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ttereshc

#5 Updated by ttereshc over 2 years ago

  • Status changed from ASSIGNED to CLOSED - WORKSFORME

Tried RHEL6 repo and Fedora 28 repo, works fine, can't reproduce.

Feel free to reopen and post a link to the url you were syncing from.

#6 Updated by bmbouter over 2 years ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF