Project

Profile

Help

Issue #436

Add to the data reaper created task tags or task type

Added by ipanova@redhat.com almost 7 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Low
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.6.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:

There are tasks created for the data reaping, but they have no tags or task type. So when you are listing the tasks you cannot tell what this task was about, its purpose and where it comes from.

[root@ec2-54-246-60-188 ~]# pulp-admin -u admin -p admin tasks list
----------------------------------------------------------------------
Tasks
--------------------------------------------------------------------

Operations:
Resources:
State: Successful
Start Time: 2014-05-24T22:35:23Z
Finish Time: 2014-05-24T22:35:23Z
Task Id: cb5e3318-b3d9-4568-812d-f92113dd0857

Operations:
Resources:
State: Successful
Start Time: 2014-05-25T22:35:23Z
Finish Time: 2014-05-25T22:35:24Z
Task Id: a4558b39-d412-4583-afb3-78ee1e119956

Operations: sync
Resources: xxx (repository)
State: Successful
Start Time: 2014-05-26T09:51:18Z
Finish Time: 2014-05-26T09:51:19Z
Task Id: 7bf6807c-0ad2-4d92-b22c-833a35634a67

Operations: delete
Resources: xxx (repository)
State: Successful
Start Time: 2014-05-26T09:53:24Z
Finish Time: 2014-05-26T09:53:25Z
Task Id: 93ed4b84-6c5f-458e-a782-125b64a20141

[root@ec2-54-246-60-188 ~]# pulp-admin -u admin -p admin tasks details --task-id 93ed4b84-6c5f-458e-a782-125b64a20141
----------------------------------------------------------------------
Task Details
--------------------------------------------------------------------

Operations: delete
Resources: xxx (repository)
State: Successful
Start Time: 2014-05-26T09:53:24Z
Finish Time: 2014-05-26T09:53:25Z
Result: N/A
Task Id: 93ed4b84-6c5f-458e-a782-125b64a20141
Progress Report:

[root@ec2-54-246-60-188 ~]# pulp-admin -u admin -p admin tasks details --task-id a4558b39-d412-4583-afb3-78ee1e119956
----------------------------------------------------------------------
Task Details
--------------------------------------------------------------------

Operations:
Resources:
State: Successful
Start Time: 2014-05-25T22:35:23Z
Finish Time: 2014-05-25T22:35:24Z
Result: N/A
Task Id: a4558b39-d412-4583-afb3-78ee1e119956
Progress Report: None

Version-Release number of selected component (if applicable):
2.4.0-0.17.beta

How reproducible:

Steps to Reproduce:
1.
2.
3.

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #1101152 +

History

#1 Updated by dkliban@redhat.com almost 7 years ago

this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1120671

This should be fixed on 2.5-dev and master.

+ This comment was cloned from Bugzilla #1101152 comment 1 +

#2 Updated by cduryee almost 7 years ago

fixed in pulp 2.6.0-0.2.beta

+ This comment was cloned from Bugzilla #1101152 comment 2 +

#3 Updated by igulina@redhat.com almost 7 years ago

rpm -qa | grep pulp-server

pulp-server-2.6.0-0.2.beta.fc20.noarch

pulp-admin -u admin -p admin tasks list

--------------------------------------------------------------------
Tasks
--------------------------------------------------------------------
.....

Operations: reaper
Resources:
State: Successful
Start Time: 2014-12-23T20:56:27Z
Finish Time: 2014-12-23T20:56:27Z
Task Id: 51ef6383-dc0d-4428-8463-7ea935f66ea3

Operations: delete
Resources: test (repository)
State: Successful
Start Time: 2014-12-23T23:43:27Z
Finish Time: 2014-12-23T23:43:27Z
Task Id: 4bfc4a02-3405-4661-843a-294208cb90f3

Operations: reaper
Resources:
State: Successful
Start Time: 2014-12-24T04:53:04Z
Finish Time: 2014-12-24T04:53:04Z
Task Id: a4eb34bf-a38d-483c-9175-743ab64ff0d3

Operations: reaper
Resources:
State: Successful
Start Time: 2014-12-24T10:53:03Z
Finish Time: 2014-12-24T10:53:04Z
Task Id: 2ecf028d-80db-4fe6-a60b-9d18af4604a4

pulp-admin -u admin -p admin tasks details --task-id 2ecf028d-80db-4fe6-a60b-9d18af4604a4

--------------------------------------------------------------------
Task Details
--------------------------------------------------------------------

Operations: reaper
Resources:
State: Successful
Start Time: 2014-12-24T10:53:03Z
Finish Time: 2014-12-24T10:53:04Z
Result: N/A
Task Id: 2ecf028d-80db-4fe6-a60b-9d18af4604a4
Progress Report:

+ This comment was cloned from Bugzilla #1101152 comment 3 +

#4 Updated by bmbouter almost 7 years ago

  • Severity changed from Medium to 2. Medium

#5 Updated by rbarlow over 6 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#7 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF