Project

Profile

Help

Issue #4307

Schema shows pulp_file content endpoints instead of all pulp api endpoints

Added by ttereshc 9 months ago. Updated 6 months ago.

Status:
CLOSED - WORKSFORME
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

http://localhost:8000/pulp/api/v3/

info:
  description: ''
  title: Pulp API
  version: ''
openapi: 3.0.0
paths:
  /pulp/api/v3/:
    get:
      description: ViewSet for FileContent.
      operationId: v3_list
      parameters:
      - in: query
        name: page
        schema:
          description: A page number within the paginated result set.
          title: !!python/tuple
          - Page
          type: integer
      - in: query
        name: page_size
        schema:
          description: Number of results to return per page.
          title: !!python/tuple
          - Page size
          type: integer
      - in: query
        name: relative_path
        schema:
          description: Filter results where relative_path matches value
          title: !!python/tuple
          - ''
          type: string
      - in: query
        name: digest
        schema:
          description: Filter results where digest matches value
          title: !!python/tuple
          - ''
          type: string
      - in: query
        name: repository_version
        schema:
          description: Repository Version referenced by HREF
          title: !!python/tuple
          - ''
          type: string
      - in: query
        name: repository_version_added
        schema:
          description: Repository Version referenced by HREF
          title: !!python/tuple
          - ''
          type: string
      - in: query
        name: repository_version_removed
        schema:
          description: Repository Version referenced by HREF
          title: !!python/tuple
          - ''
          type: string
      tags:
      - v3
    post:
      description: Create a new FileContent from a request.
      operationId: v3_create
      tags:
      - v3
  /pulp/api/v3/{_id}/:
    get:
      description: ViewSet for FileContent.
      operationId: v3_read
      parameters:
      - in: path
        name: _id
        required: true
        schema:
          description: A unique integer value identifying this file content.
          title: !!python/tuple
          - ' id'
          type: integer
      tags:
      - v3
servers:
- url: http://localhost:8000/pulp/api/v3/
schema_output_fresh_install.txt (19.8 KB) bmbouter, 01/11/2019 08:38 PM schema_output_fresh_install.txt

History

#1 Updated by ttereshc 9 months ago

If someone can reproduce it (so it's not an issue on my machine only), it should be an RC blocker, imo. I set it just in case.

#2 Updated by bmbouter 9 months ago

I could not reproduce this. Attached is a text file w/ the entire output from my GET of pulp/api/v3/ and it shows core and the plugins I have installed.

#3 Updated by dkliban@redhat.com 9 months ago

  • Status changed from NEW to CLOSED - WORKSFORME

I was not able to reproduce on the latest pulp and pulp_file checkout.

#4 Updated by daviddavis 6 months ago

  • Sprint/Milestone set to 3.0

#5 Updated by bmbouter 6 months ago

  • Tags deleted (Pulp 3, Pulp 3 RC Blocker)

Please register to edit this issue

Also available in: Atom PDF