Project

Profile

Help

Task #3950

Tag model

Added by jortel@redhat.com almost 2 years ago. Updated 7 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:

Description

Create the Tag model.

Tag(Content):

  • name CharField(255)
  • manifest ForeignKey(Manifest, null=True, related_name='tags', on_delete=CASCADE)
  • manifest_list ForeignKey(ManifestList, null=True, related_name='tags', on_delete=CASCADE)

unique_together = (name, manifest)
unique_together = (name, manifest_list)

Design assumptions:

  • Pre-save validation on the model ensures that one-of but not both manifest and manifest_list are set.
  • Tag name uniqueness and referential integrity{1} will be enforced by the plugin. During sync, this happens in the task logic. For content add/remove API calls, this happens in the (docker specific) view. Both can re-use the same code.

[1] Tag referential integrity is ensuring that when a manifest or manifest_list is removed from a repository, referencing tags are also removed. Also, when a tag is added to a repository, referenced manifest or manifest_list are also added.


Related issues

Is duplicate of Container Support - Story #3401: Create content models for pulp_docker 4.0CLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by jortel@redhat.com almost 2 years ago

  • Blocked by Story #3401: Create content models for pulp_docker 4.0 added

#2 Updated by jortel@redhat.com almost 2 years ago

  • Description updated (diff)

#3 Updated by jortel@redhat.com almost 2 years ago

  • Description updated (diff)

#4 Updated by jortel@redhat.com almost 2 years ago

  • Description updated (diff)

#5 Updated by jortel@redhat.com almost 2 years ago

  • Description updated (diff)

#6 Updated by jortel@redhat.com almost 2 years ago

  • Description updated (diff)

#7 Updated by jortel@redhat.com almost 2 years ago

  • Description updated (diff)

#8 Updated by amacdona@redhat.com over 1 year ago

  • Status changed from NEW to MODIFIED

Moved to MODIFIED since there is no "closed" for tasks. This one duplicates https://pulp.plan.io/issues/3401, which ended up also covering tags.

#9 Updated by amacdona@redhat.com over 1 year ago

  • Blocked by deleted (Story #3401: Create content models for pulp_docker 4.0)

#10 Updated by amacdona@redhat.com over 1 year ago

  • Is duplicate of Story #3401: Create content models for pulp_docker 4.0 added

#11 Updated by bmbouter over 1 year ago

  • Tags deleted (Pulp 3)

#12 Updated by ipanova@redhat.com 9 months ago

  • Project changed from Docker Support to Container Support

#13 Updated by ipanova@redhat.com 8 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#14 Updated by ipanova@redhat.com 7 months ago

  • Sprint/Milestone set to 1.0.0

Please register to edit this issue

Also available in: Atom PDF