Project

Profile

Help

Issue #3946

Syncing from Galaxy is not working

Added by daviddavis about 1 year ago. Updated 7 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
Severity:
3. High
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:
Sprint 42

Description

It looks like some fields were renamed in the Galaxy API. From the Galaxy team:

Change the namespace query referenced in your email to: "https://galaxy.ansible.com/api/v1/roles/?namespace__name=ansible". Namespace is now an object in galaxy, so it has an id, description, name, and other attributes that you can query.

There is no longer a 'num_pages' value returned in the response object. We return the number of results as 'count', so you can do something like, "math.ceil(float(count)/float(page_size))", in Python to calc the number of pages.

Associated revisions

Revision 83f37760 View on GitHub
Added by daviddavis about 1 year ago

Updating the sync code due to breaking changes in Galaxy in API

fixes #3946
https://pulp.plan.io/issues/3946

History

#1 Updated by bmbouter about 1 year ago

  • Severity changed from 2. Medium to 3. High
  • Sprint set to Sprint 42

We need to get this fixed ASAP since we now know the regression won't be reversed.

#2 Updated by daviddavis about 1 year ago

  • Status changed from NEW to POST

#3 Updated by daviddavis about 1 year ago

  • Status changed from POST to MODIFIED

#4 Updated by bmbouter about 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#5 Updated by bmbouter 7 months ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF