Project

Profile

Help

Issue #3905

closed

Purge for unlinked manifests is not working correctly

Added by ipanova@redhat.com almost 6 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Docker:
Platform Release:
2.17.0
Target Release - Docker:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 41
Quarter:

Description

Steps to reproduce:

1. pulp-admin docker repo create --repo-id=synctest --feed=https://registry-1.docker.io --upstream-name=busybox --tags=latest

2) sync repo

[ipanova@ina pulp_docker]$ pulp-admin docker repo list

--------------------------------------------------------------------
Docker Repositories
--------------------------------------------------------------------

Id: synctest
Display Name: None
Description: None
Content Unit Counts:
Docker Blob: 17
Docker Manifest: 9
Docker Manifest List: 1
Docker Tag: 2

3) remove 1 manifest list by specifying its digest

pulp-admin -vv docker repo remove manifest-list --repo-id synctest --str-eq='digest=sha256:cb63aa0641a885f54de20f61d152187419e8f6b159ed11a251a09d115fdff9bd'

4) observe that number of docker manifests did not change, that means manifests where not purged as they should been

[ipanova@ina pulp_docker]$ pulp-admin docker repo list

--------------------------------------------------------------------
Docker Repositories
--------------------------------------------------------------------

Id: synctest
Display Name: None
Description: None
Content Unit Counts:
Docker Blob: 17
Docker Manifest: 9
Docker Manifest List: 0
Docker Tag: 1

Expected behaviour:

4) observe that number of docker manifest decreased, because unlinked manifests were removed with manifest list removal

[ipanova@ina pulp_docker]$ pulp-admin docker repo list

--------------------------------------------------------------------
Docker Repositories
--------------------------------------------------------------------

Id: synctest
Display Name: None
Description: None
Content Unit Counts:
Docker Blob: 2
Docker Manifest: 1
Docker Manifest List: 0
Docker Tag: 1

Actions #1

Updated by ipanova@redhat.com almost 6 years ago

  • Project changed from Pulp to Docker Support
  • Status changed from NEW to POST
  • Sprint/Milestone set to 2.17.0
Actions #2

Updated by ipanova@redhat.com almost 6 years ago

  • Description updated (diff)

Added by ipanova@redhat.com almost 6 years ago

Revision 22209b17 | View on GitHub

Fix removal of embedded manifests in manifest list.

closes#3905 https://pulp.plan.io/issues/3905

Actions #3

Updated by CodeHeeler almost 6 years ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 41
Actions #4

Updated by ipanova@redhat.com almost 6 years ago

  • Status changed from POST to MODIFIED
Actions #5

Updated by ipanova@redhat.com almost 6 years ago

  • Platform Release set to 2.17.0
Actions #6

Updated by ipanova@redhat.com almost 6 years ago

  • Platform Release changed from 2.17.0 to master
Actions #7

Updated by ipanova@redhat.com almost 6 years ago

  • Platform Release deleted (master)
Actions #8

Updated by ipanova@redhat.com almost 6 years ago

  • Platform Release set to 2.17.0
Actions #9

Updated by ipanova@redhat.com almost 6 years ago

  • Assignee set to ipanova@redhat.com
Actions #10

Updated by ipanova@redhat.com almost 6 years ago

  • Status changed from MODIFIED to 5
Actions #11

Updated by ipanova@redhat.com almost 6 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE
Actions #12

Updated by bmbouter over 5 years ago

  • Tags Pulp 2 added
Actions #13

Updated by ttereshc over 2 years ago

  • Sprint/Milestone deleted (2.17.0)

Also available in: Atom PDF