Project

Profile

Help

Issue #3881

FileDownloader Destroys my Data

Added by bmbouter about 1 year ago. Updated 6 months ago.

Status:
CLOSED - NOTABUG
Priority:
Normal
Category:
-
Sprint/Milestone:
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:
Sprint 42

Description

Problem

If you use file:// as your protocol handler with a remote.feed Pulp will move your file into the backend. If you have a backup of your published data, you probably don't want it destroying the original copy.

Solution

The FileDownloader should save a copy of the data into the working directory just like the HttpDownloader does. This will cause the data to be copied and the original source left alone. Then when being moved into the backend it will already be on the same filesystem for the final move.

History

#1 Updated by CodeHeeler about 1 year ago

  • Triaged changed from No to Yes
  • Sprint set to Sprint 40

#2 Updated by rchan about 1 year ago

  • Sprint changed from Sprint 40 to Sprint 41

#3 Updated by jortel@redhat.com about 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jortel@redhat.com

#4 Updated by jortel@redhat.com about 1 year ago

@bmbouter: I use file:/// urls all the time when testing the File pluign and have not observed the behavior you've described. What am I missing?

#5 Updated by rchan about 1 year ago

  • Sprint changed from Sprint 41 to Sprint 42

#6 Updated by bmbouter about 1 year ago

  • Status changed from ASSIGNED to CLOSED - NOTABUG

I tried to reproduce this locally with the latest pulp_file and a local PULP_MANIFEST repo. I couldn't reproduce it like I was before. I think this has to be closed NOTABUG so I'm doing that now.

@jortel thank you for looking into this, and also for asking me to test it again also. Sorry it took me so long to get around to it.

#7 Updated by daviddavis 6 months ago

  • Sprint/Milestone set to 3.0

#8 Updated by bmbouter 6 months ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF