Project

Profile

Help

Issue #351

orphan remove removes the content but the empty directories not deleted

Added by pthomas@redhat.com over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Low
Category:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
Master
Platform Release:
2.8.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
After the contents are removed by orphan remove, the empty directories needs to be cleaned up as well

Version-Release number of selected component (if applicable):

[root@qeblade3 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.13.alpha.fc18.noarch

How reproducible:

Steps to Reproduce:
1. create and sync a repo
2.Delete the repo
3. Orphan remove the content
4. see that /var/lib/pulp/content/rpm/../.. are still exisiting

Actual results:

Expected results:

Additional info:

+ This bug was cloned from Bugzilla Bug #966676 +


Related issues

Is duplicate of Pulp - Issue #1238: remove orphaned content does not perform full cleanupCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by pthomas@redhat.com over 5 years ago

[root@qeblade3 ~]# ls -l /var/lib/pulp/content/rpm/zip/3.0/5.fc18/x86_64/b0f6819fa2d78ab38a8656cc6b41b784892f5829a9cc8f2cbc503703e92fa19f/Packages/z/
total 0
[root@qeblade3 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.13.alpha.fc18.noarch
[root@qeblade3 ~]#

+ This comment was cloned from Bugzilla #966676 comment 1 +

#2 Updated by cduryee over 5 years ago

This bug is still outstanding as of 2.5.0.

+ This comment was cloned from Bugzilla #966676 comment 2 +

#3 Updated by cduryee over 5 years ago

***** Bug 1018949 has been marked as a duplicate of this bug. ***

+ This comment was cloned from Bugzilla #966676 comment 3 +

#4 Updated by amacdona@redhat.com almost 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to amacdona@redhat.com
  • Severity set to 1. Low

#5 Updated by amacdona@redhat.com almost 5 years ago

  • Is duplicate of Issue #1238: remove orphaned content does not perform full cleanup added

#6 Updated by amacdona@redhat.com almost 5 years ago

  • Status changed from ASSIGNED to POST

#7 Updated by amacdona@redhat.com almost 5 years ago

  • Status changed from POST to MODIFIED

#8 Updated by rbarlow over 4 years ago

  • Status changed from MODIFIED to 5
  • Platform Release set to 2.8.0

#9 Updated by dkliban@redhat.com over 4 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#10 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF