Project

Profile

Help

Task #3407

closed

Upgrade the Celery stack that Pulp ships on EL7 to Celery + Kombu 4.x

Added by dalley over 6 years ago. Updated about 5 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
2.16.0
Target Release - Packaging:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Celery 3.x is EOL, and has a couple of known issues which are not resolvable without some very risky backports. Additionally, Pulp is currently supporting both Celery 3.x and 4.x, resulting in double the testing load when we come across an issue relating to Celery.

Fedora has been shipping Celery 4.x for several months, ever since the release of Fedora 26 last year. Thus, we know Pulp is fairly stable with these versions of the dependencies.

I propose that we upgrade the carried versions of Celery, Kombu, and their dependencies to the ones currently being shipped in Fedora 27.

The full list of packages to build is:

  • python-celery 4.0.2-3 (will change pending below changes)
  • python-kombu 4.0.2-8 (will change pending below changes)
  • python-amqp 2.2.2-1
  • python-billiard 3.5.0.3-1
  • python-vine 1.1.3-3

Also available in: Atom PDF