Project

Profile

Help

Issue #3362

Pypi install steps are missing the makemigrations command and therefore produce broken installations

Added by milan over 2 years ago. Updated 6 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Severity:
2. Medium
Version:
Master
Platform Release:
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:
Sprint 33

Description

Based on the Plugin Writer's Coding Workshop Feedback, the installation issues, the pypi install commands are missing the migrations and they produce broken installations.

Associated revisions

Revision a145d061 View on GitHub
Added by milan over 2 years ago

Add the missing makemigrations Pypi install step

The Pypi installation instructions missed the makemigrations step.

Fixes #3362 https://pulp.plan.io/issues/3362

Revision a145d061 View on GitHub
Added by milan over 2 years ago

Add the missing makemigrations Pypi install step

The Pypi installation instructions missed the makemigrations step.

Fixes #3362 https://pulp.plan.io/issues/3362

History

#2 Updated by bmbouter over 2 years ago

  • Priority changed from Normal to High

The PyPi installation docs are here: https://docs.pulpproject.org/en/3.0/nightly/installation/instructions.html#pypi-installation

I think it's separate from the db-reset script. I think the issue is that there is no step to makemigrations and there must be to produce a working installation.

I think it's right that this be an issue because it's a defect in the installation guide. +1 to adding it to the sprint. It's high priority so I'm changing it to high.

#3 Updated by dalley over 2 years ago

  • Sprint/Milestone set to 56
  • Triaged changed from No to Yes
  • Tags Documentation added

#4 Updated by milan over 2 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to milan

#5 Updated by milan over 2 years ago

  • Subject changed from Pypi install commands are missing the migrations and they produce broken installations to Pypi install steps are missing the makemigrations command and therefore produce broken installations

#6 Updated by milan over 2 years ago

  • Status changed from ASSIGNED to POST

#7 Updated by milan over 2 years ago

#8 Updated by milan over 2 years ago

  • Status changed from POST to MODIFIED

#9 Updated by bmbouter about 2 years ago

  • Sprint set to Sprint 33

#10 Updated by bmbouter about 2 years ago

  • Sprint/Milestone deleted (56)

#11 Updated by daviddavis about 1 year ago

  • Sprint/Milestone set to 3.0.0

#12 Updated by bmbouter about 1 year ago

  • Tags deleted (Pulp 3)

#13 Updated by bmbouter 6 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF