Project

Profile

Help

Story #3119

As a user, I can see in logs that force_full option for sync or publish is enabled

Added by ttereshc about 4 years ago. Updated almost 3 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

100%

Estimated time:
Platform Release:
2.15.0
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
Pulp 2
Sprint:
Sprint 28
Quarter:

Description

It is possible that users configure importer/distributor to have force_full enabled and forget about it.
For example, Katello users can enable "force_full" sync or publish. This is usually done as part of debugging, but it's easy to set it and then forget to turn it off. The issue is not apparent until later on when there are performance issues with sync/publish.

Logging that force_full is used would help with debugging performance issues.

Log at INFO level and only when force_full option is set to True.
Message should specify the behavior the enabled option causes, e.g.:
- "fully resyncing due to use of force_full importer setting"
- "fully republishing due to use of force_full distributor setting"

Associated revisions

Revision 82ea3193 View on GitHub
Added by dalley about 4 years ago

Log scenarios where a full sync or publish is being forced

closes #3119 https://pulp.plan.io/issues/3119

History

#1 Updated by ttereshc about 4 years ago

I think it can be useful because force_full is not supposed to be used every time but for certain cases.
I suggest to use INFO log level.

#2 Updated by mhrivnak about 4 years ago

Agreed. This option changes the behavior of the task substantially, so I think it's reasonable to log at INFO. I suggest only logging a message when it is set to true, and focus the message on the behavior. Something like "fully republishing due to use of force_full setting".

#3 Updated by ttereshc about 4 years ago

  • Description updated (diff)

#4 Updated by mhrivnak about 4 years ago

  • Sprint/Milestone set to 47
  • Groomed changed from No to Yes
  • Sprint Candidate changed from No to Yes

#5 Updated by dalley about 4 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to dalley

#6 Updated by dalley about 4 years ago

  • Status changed from ASSIGNED to POST

#7 Updated by dalley about 4 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#8 Updated by pcreech about 4 years ago

  • Platform Release set to 2.15.0

#9 Updated by pcreech about 4 years ago

  • Status changed from MODIFIED to 5

#10 Updated by pcreech about 4 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#11 Updated by bmbouter almost 4 years ago

  • Sprint set to Sprint 28

#12 Updated by bmbouter almost 4 years ago

  • Sprint/Milestone deleted (47)

#13 Updated by bmbouter almost 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF