Project

Profile

Help

Issue #3104

repomd.xml is empty

Added by Ichimonji10 almost 3 years ago. Updated 2 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.15.0
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:

Description

When Pulp publishes and RPM repository, it places a number of files in a repodata directory. The most important of these files is the repomd.xml file. This file tells clients where all other files live. When Pulp 2.15 publishes an RPM file, all repomd.xml files are empty.

Here's a simple way to reproduce the issue:

pulp-admin login -u admin -p admin
pulp-admin rpm repo create --repo-id foo --feed https://repos.fedorapeople.org/pulp/pulp/fixtures/rpm-unsigned/
pulp-admin rpm repo sync run --repo-id foo
find /var/lib/pulp -name repomd.xml -exec wc '{}' ';'

In my case, here's the final line of output:

0 0 0 /var/lib/pulp/published/yum/master/yum_distributor/foo/1509121269.36/repodata/repomd.xml

This issue affects Pulp 2.15 on F24, F25 and RHEL 7. It probably affects Pulp 2.15 on F26 too, but there's installation issues there, so I can't say for sure.

This issue isn't caused by SELinux. I can reproduce the issue with SELinux disabled. Also, there's no AVC denials in the system logs.

This issue occurs in a wide varity of situations. Several dozen Pulp Smash test cases all fail because of this.

3104.txt (2.46 KB) 3104.txt pcreech, 10/27/2017 09:36 PM
clipboard-201910111003-x4qs7.png (1.63 KB) clipboard-201910111003-x4qs7.png bailyd17, 10/11/2019 06:33 AM
clipboard-201910111004-gopg5.png (1.89 KB) clipboard-201910111004-gopg5.png bailyd17, 10/11/2019 06:34 AM
clipboard-201910111004-fulry.png (1.89 KB) clipboard-201910111004-fulry.png bailyd17, 10/11/2019 06:34 AM
250
250
250

Associated revisions

Revision b3e2dd8b View on GitHub
Added by Paul Donohue almost 3 years ago

Add missing super() call in f73805f6

re #3055 https://pulp.plan.io/issues/3055

History

#1 Updated by mhrivnak almost 3 years ago

I did a fresh "vagrant up" of all the master branches for pulp 2. The vagrant box uses Fedora 25. I followed exactly your steps, although I had to be the "apache" user for both the "find" and "wc" commands. So far Pulp is creating the repomd.xml correctly.

[vagrant@pulp2 ~]$ sudo -u apache wc /var/lib/pulp/published/yum/master/yum_distributor/foo/1509123641.08/repodata/repomd.xml
   8   36 2153 /var/lib/pulp/published/yum/master/yum_distributor/foo/1509123641.08/repodata/repomd.xml

#2 Updated by Ichimonji10 almost 3 years ago

This may affect only our package-based installations. This affects systems on Jenkins, and all of my systems used package-based installations.

#3 Updated by pcreech almost 3 years ago

Adding output from a clean fresh install I did from the install guide at docs.pulpproject.org pointing to the nightly repos on fedorapeople.org

#4 Updated by mhrivnak almost 3 years ago

When I got on the VM pcreech provided, I found that the repomd.xml file was still being held open by the worker process. Here is select output from "lsof":

celery    11915        apache  cwd       DIR               0,18       100      33131 /run/pulp
celery    11915        apache   19w      REG              253,0         0   16963172 /var/lib/pulp/published/yum/master/yum_distributor/foo/1509132750.65/repodata/repomd.xml
celery    11915 11917  apache  cwd       DIR               0,18       100      33131 /run/pulp
celery    11915 11917  apache   19w      REG              253,0         0   16963172 /var/lib/pulp/published/yum/master/yum_distributor/foo/1509132750.65/repodata/repomd.xml
celery    11915 11919  apache  cwd       DIR               0,18       100      33131 /run/pulp
celery    11915 11919  apache   19w      REG              253,0         0   16963172 /var/lib/pulp/published/yum/master/yum_distributor/foo/1509132750.65/repodata/repomd.xml
celery    11915 12068  apache  cwd       DIR               0,18       100      33131 /run/pulp
celery    11915 12068  apache   19w      REG              253,0         0   16963172 /var/lib/pulp/published/yum/master/yum_distributor/foo/1509132750.65/repodata/repomd.xml
celery    11915 12069  apache  cwd       DIR               0,18       100      33131 /run/pulp
celery    11915 12069  apache   19w      REG              253,0         0   16963172 /var/lib/pulp/published/yum/master/yum_distributor/foo/1509132750.65/repodata/repomd.xml
celery    11915 12072  apache  cwd       DIR               0,18       100      33131 /run/pulp
celery    11915 12072  apache   19w      REG              253,0         0   16963172 /var/lib/pulp/published/yum/master/yum_distributor/foo/1509132750.65/repodata/repomd.xml

#5 Updated by bmbouter almost 3 years ago

  • Status changed from NEW to MODIFIED
  • Assignee set to PaulSD

I'm thinking that this broke with this [0] PR and was fixed when this PR [1] got merged. Specifically there was a missing call to finalize() which is now back in place. So with that in mind I'm associating that commit and moving to MODIFIED. Since we're sending back after a failure I'm marking Verification Required as True.

[0]: https://github.com/pulp/pulp_rpm/pull/1065
[1]: https://github.com/pulp/pulp_rpm/pull/1067

#6 Updated by PaulSD almost 3 years ago

Agreed, the missing finalize() call caused similar behavior during my testing, and should be fixed with the second PR.

#7 Updated by Ichimonji10 almost 3 years ago

  • Description updated (diff)

#8 Updated by pcreech over 2 years ago

  • Platform Release set to 2.15.0

#9 Updated by pcreech over 2 years ago

  • Status changed from MODIFIED to 5

#10 Updated by Ichimonji10 over 2 years ago

There are numerous tests already targeting this issue, and they all pass.

#11 Updated by pcreech over 2 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#12 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

#13 Updated by lostman about 1 year ago

This has been a challenging time, and I appreciate you so much.
http://setpoffice.com/setup

#14 Updated by bailyd17 10 months ago

250
250
250

This is really nice. I would like to thank you for the information in this article you gave to us. If Someone looking for help for your programming assignment or homework? No-hassle our expert will help you to provide the programming assignment and homework help.

[[https://www.allassignmenthelp.com/programming-language-assignment-help.html]]

#15 Updated by gnyanesh.factocert@gmail.com 6 months ago

Good. I really like this, I just found out about this. This was an incredibly wonderful article. Thanks for providing these details.

http://factocert.com/iso-9001-certification-in-bahrain/ |http://factocert.com/iso-14001-certification-in-bahrain/ | http://factocert.com/iso-9001-certification-in-philippines/

#16 Updated by JessicaJones121 5 months ago

I would like to thank you for the efforts and thoughts you have made in writing this blog content. I am hoping the same best work from you in the future as well. https://www.godissertationhelp.co.uk/dissertation-abstract/ https://www.godissertationhelp.co.uk/dissertation-conclusion/ https://www.godissertationhelp.co.uk/dissertation-structure/

#17 Updated by iso9001 3 months ago

This is a really instructive post, you're an incredibly skilled blogger. I've joined your blog searching for a more noteworthy measure of your brilliant post. Moreover, I have shared your site on my informal communities! [[http://factocert.com/iso-9001-certification-in-saudi-arabia]]

#18 Updated by anika117 2 months ago

There is just the information I find everywhere. Thanks for your blog, I subscribe to your blog. This is a good blog. for any kind of academic assistance, you can get Help With Dissertation Writing Services London UK.

#19 Updated by hannahberry 2 months ago

I am very pleased to read your article. I signed up to know more about the content and format of the article. I also have a pretty interesting website, you can visit the geometry dash. It's pleasure to serve you.

Please register to edit this issue

Also available in: Atom PDF