Project

Profile

Help

Issue #3100

Removal of existing iso units doesn't work if there are multiple iso files

Added by daviddavis about 2 years ago. Updated 7 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version:
Platform Release:
2.14.3
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
Yes
Verification Required:
No
Sprint:
Sprint 28

Description

This is similar to #3047 and #2773. We added code to remove duplicate ISOs however, this code doesn't work after one iteration. Looks like a generator type was being used instead of a list:

https://github.com/pulp/pulp_rpm/blob/23492381f285f2799aa894f8834e3fbc40b3ac72/plugins/pulp_rpm/plugins/importers/iso/sync.py#L333

Steps to reproduce:

export REPO1='iso-1'
export REPO2='iso-2'
mkdir /tmp/iso
cd /tmp/iso

echo "test1" > 1.iso
echo "test2" > 2.iso
echo 1.iso,`sha256sum 1.iso | awk '{ print $1 }'`,`stat -L -c '%s' 1.iso` > PULP_MANIFEST
echo 2.iso,`sha256sum 2.iso | awk '{ print $1 }'`,`stat -L -c '%s' 2.iso` >> PULP_MANIFEST

pulp-admin iso repo create --repo-id $REPO1 --feed file:///tmp/iso
pulp-admin iso repo sync run --repo-id $REPO1
pulp-admin iso repo create --repo-id $REPO2 --feed file:///tmp/iso
pulp-admin iso repo sync run --repo-id $REPO2

echo "blah1" > 1.iso
echo "blah2" > 2.iso
echo 1.iso,`sha256sum 1.iso | awk '{ print $1 }'`,`stat -L -c '%s' 1.iso` > PULP_MANIFEST
echo 2.iso,`sha256sum 2.iso | awk '{ print $1 }'`,`stat -L -c '%s' 2.iso` >> PULP_MANIFEST

pulp-admin iso repo sync run --repo-id $REPO1
pulp-admin iso repo sync run --repo-id $REPO2

pulp-admin iso repo list

You'll see that the repos have 3 units instead of 2. One of the existing dupe units is removed but the other is not.


Related issues

Related to RPM Support - Issue #3047: ISO repo doesn't correctly handle updates to files for content already in Pulp CLOSED - CURRENTRELEASE Actions

Associated revisions

Revision 5d24a824 View on GitHub
Added by daviddavis about 2 years ago

Changing the type of repo_units to list from generator

The repo_units value was emptying after iterating through it because it
was a generator and not a list.

fixes #3100
https://pulp.plan.io/issues/3100

History

#1 Updated by daviddavis about 2 years ago

  • Description updated (diff)

#2 Updated by daviddavis about 2 years ago

  • Status changed from NEW to POST
  • Assignee set to daviddavis

#3 Updated by daviddavis about 2 years ago

  • Related to Issue #3047: ISO repo doesn't correctly handle updates to files for content already in Pulp added

#4 Updated by dalley about 2 years ago

  • Sprint/Milestone set to 46
  • Triaged changed from No to Yes

#5 Updated by mhrivnak about 2 years ago

  • Sprint/Milestone changed from 46 to 47

#6 Updated by daviddavis about 2 years ago

  • Status changed from POST to MODIFIED

#7 Updated by pcreech about 2 years ago

  • Platform Release set to 2.14.3

#8 Updated by pcreech about 2 years ago

  • Status changed from MODIFIED to ON_QA

#9 Updated by pthomas@redhat.com about 2 years ago

See Issue #3047 for verification steps.

#10 Updated by pthomas@redhat.com about 2 years ago

  • Verified changed from No to Yes

#11 Updated by bmbouter almost 2 years ago

  • Sprint set to Sprint 28

#12 Updated by bmbouter almost 2 years ago

  • Sprint/Milestone deleted (47)

#14 Updated by bmbouter 8 months ago

  • Tags Pulp 2 added

#15 Updated by daviddavis 7 months ago

  • Status changed from ON_QA to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF