Project

Profile

Help

Issue #2773

ISO repo does not handle updates to files on manifest during re-sync correctly

Added by mhrivnak about 3 years ago. Updated about 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Severity:
3. High
Version:
2.9.3
Platform Release:
2.13.3
Blocks Release:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
Yes
Sprint Candidate:
Yes
Tags:
Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:
Sprint 22

Description

Copied from Bugzilla thanks to Craig Donnelly:

Description of problem:

Currently, if you generate a PULP_MANIFEST and sync from another location via URL, you will receive the files in the Manifest and they will become locally available, but if you UPDATE a file that has already been imported and regenerate the PULP_MANIFEST, then sync again, Pulp's versions of the manifest will have a duplicate file name entry with separate sha256sums and sizes, but will not retrieve the new file (It will maintain the original in the repo).

Version-Release number of selected component (if applicable):
pulp-server-2.9.3-2.el7sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. Generate PULP_MANIFEST and sync a File repo from a http based URL
2. Make a change to a file (text file, etc..), but DO NOT change the file NAME.
3. Re-Generate the PULP_MANIFEST for the remote file repo, and then re-sync on Satellite.

Actual results:
File that was modified will have two entries on the PULP_MANIFEST inside the local Satellite copy of the repo with separate sha256sums and sizes, but identical name, and only the original copy of the file prior to editing will exist in the repo.

Expected results:
We should replace original file with the newest checksum. (Act like mirror-on-sync?)

Additional info:
Perhaps the File repo type should be able to determine the time of PULP_MANIFEST generation and make a determination about what should exist based off of that? (i.e. Include a date inside the PULP_MANIFEST on creation)


Related issues

Related to RPM Support - Issue #3047: ISO repo doesn't correctly handle updates to files for content already in Pulp CLOSED - CURRENTRELEASE Actions

Associated revisions

Revision 4db15dc8 View on GitHub
Added by daviddavis almost 3 years ago

Fixing dupe ISO units after file update

Fixing a bug whereby a ISO or file gets updated and then reimported into pulp by sync or upload. We're now disassociating the original content unit and replacing it with the new one. Matching on the name of the unit.

fixes #2773 https://pulp.plan.io/issues/2773

History

#1 Updated by mhrivnak about 3 years ago

  • Description updated (diff)
  • Version set to 2.9.3

#2 Updated by ttereshc about 3 years ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes

#3 Updated by pthomas@redhat.com about 3 years ago

  • Smash Test set to 664

#4 Updated by ttereshc almost 3 years ago

  • Sprint Candidate changed from No to Yes

#6 Updated by pcreech almost 3 years ago

  • Groomed changed from No to Yes

#7 Updated by mhrivnak almost 3 years ago

  • Sprint/Milestone set to 40

#8 Updated by daviddavis almost 3 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to daviddavis

#9 Updated by daviddavis almost 3 years ago

  • Status changed from ASSIGNED to POST

#10 Updated by mhrivnak almost 3 years ago

  • Sprint/Milestone changed from 40 to 41

#11 Updated by daviddavis almost 3 years ago

  • Status changed from POST to MODIFIED

#12 Updated by pcreech almost 3 years ago

  • Platform Release set to 2.13.3

#13 Updated by pcreech almost 3 years ago

  • Status changed from MODIFIED to ON_QA

#14 Updated by pcreech almost 3 years ago

  • Status changed from ON_QA to CLOSED - CURRENTRELEASE

#15 Updated by daviddavis over 2 years ago

  • Related to Issue #3047: ISO repo doesn't correctly handle updates to files for content already in Pulp added

#16 Updated by bmbouter about 2 years ago

  • Sprint set to Sprint 22

#17 Updated by bmbouter about 2 years ago

  • Sprint/Milestone deleted (41)

#20 Updated by bmbouter about 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF