Drop Python 3.4 support
- Pulp 3 is not expected to support EL6, where SCL is available for Python 3.4 only
- There is Python 3.5 SCL for EL7 available.
- Next Django release (2.0) will support Python 3.5+
- No impact on Django version choice, both Django LTS versions, 1.8 and 1.11, support Python 3.5
- Next major Celery release will support only Python 3.5
#4 Updated by email@example.com over 2 years ago
When I ported the style guide, I prematurely stated we were going to use 3.5+.
If we close this issue for some reason, please change that line to 3.4.
#5 Updated by mhrivnak over 2 years ago
- Subject changed from Consider dropping Python 3.4 support to Drop Python 3.4 support
- Status changed from NEW to ASSIGNED
- Assignee set to bizhang
- Sprint/Milestone set to 41
- Sprint Candidate changed from No to Yes
Tanya pointed out that it will be good for plugin writers to understand what Python versions they can work with.
#6 Updated by bizhang over 2 years ago
- Status changed from ASSIGNED to CLOSED - COMPLETE
As a part of #2842 I dropped Python 3.4 from pulpcore, pulpcore-plugin, and pulpcore-common (the 3 packages currently published on pypi) because the docs stated that we only support 3.5+
The other setup.py should be updated as we get the other packages ready for publishing.
Please register to edit this issue