Project

Profile

Help

Issue #2826

Repository deletion fails with no such file for a repositories listing file

Added by ehelms@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.21.3
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Sprint 75
Quarter:

Description

We see this error a good bit when we try to delete content view versions in Katello land. The Pulp translation is that we concurrently attempt to delete multiple repositories at the same time and 50% of the time hit this race condition in the output below.

- exception: 
  task_type: pulp.server.tasks.repository.delete
  _href: "/pulp/api/v2/tasks/fc50b7b8-093f-4111-8bf1-2b27d306dbe3/"
  task_id: fc50b7b8-093f-4111-8bf1-2b27d306dbe3
  tags:
  - pulp:repository:Sat6-CI-Tools_RHEL5-206_0-Red_Hat_Satellite_Tools_6_2_Composes-RHEL5_Satellite_Tools_i386_os
  - pulp:action:delete
  finish_time: '2017-06-20T15:55:58Z'
  _ns: task_status
  start_time: '2017-06-20T15:55:55Z'
  traceback: |
    Traceback (most recent call last):
      File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 240, in trace_task
        R = retval = fun(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 477, in __call__
        return super(Task, self).__call__(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/pulp/server/async/tasks.py", line 103, in __call__
        return super(PulpTask, self).__call__(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/celery/app/trace.py", line 437, in __protected_call__
        return self.run(*args, **kwargs)
      File "/usr/lib/python2.7/site-packages/pulp/server/controllers/repository.py", line 550, in delete
        raise pe
    PulpExecutionException: Pulp exception occurred: PulpExecutionException
  spawned_tasks: []
  progress_report: {}
  queue: reserved_resource_worker-0@sat-r220-02.lab.eng.rdu2.redhat.com.dq
  state: error
  worker_name: reserved_resource_worker-0@sat-r220-02.lab.eng.rdu2.redhat.com
  result: 
  error:
    code: PLP0000
    data: {}
    description: 'Pulp exception occurred: PulpExecutionException'
    sub_errors:
    - code: PLP0000
      data: {}
      description: "[Errno 2] No such file or directory: '/var/lib/pulp/published/yum/http/repos/Sat6-CI/content_views/Tools_RHEL5/206.0/custom/Red_Hat_Satellite_Tools_6_2_Composes/listing'"
      sub_errors: []
  _id:
    "$oid": 5949458a643234c3f51e0177
  id: 5949458a643234c3f51e0177
poll_attempts:
  total: 2
  failed: 1

Associated revisions

Revision f54315cd View on GitHub
Added by ttereshc over 1 year ago

Ensure repo deletion doesn't fail due to the absence of listing files

closes #2826 https://pulp.plan.io/issues/2826

Revision 9463f1ad View on GitHub
Added by ttereshc over 1 year ago

Ensure repo deletion doesn't fail due to the absence of listing files

closes #2826 https://pulp.plan.io/issues/2826

(cherry picked from commit f54315cd41cbc6944d56d07136db38b89ae5061f)

History

#1 Updated by ttereshc over 4 years ago

  • Triaged changed from No to Yes

@dkliban will put a comment how to reproduce it in Pulp.

#4 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

#6 Updated by pulpbot over 1 year ago

  • Status changed from NEW to POST

#7 Updated by ttereshc over 1 year ago

  • Sprint set to Sprint 75

#8 Updated by ttereshc over 1 year ago

  • Assignee set to ttereshc

#9 Updated by ttereshc over 1 year ago

  • Status changed from POST to MODIFIED

#10 Updated by ttereshc over 1 year ago

  • Project changed from Pulp to RPM Support

#11 Updated by ttereshc over 1 year ago

  • Platform Release set to 2.21.3

#15 Updated by ttereshc over 1 year ago

#16 Updated by ttereshc over 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF