Project

Profile

Help

Issue #2724

`pulp-admin docker repo create --help` states v1 content is synced by default

Added by Ichimonji10 almost 3 years ago. Updated 11 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Severity:
2. Medium
Version - Docker:
Platform Release:
2.14.0
Blocks Release:
Target Release - Docker:
OS:
Backwards Incompatible:
No
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
QA Contact:
Complexity:
Smash Test:
Verified:
Yes
Verification Required:
No
Sprint:

Description

Check out this help text:

[root@fedora-24-pulp-2-14 ~]# pulp-admin docker repo create --help
Command: create
Description: creates a new repository

Available Arguments:

  --repo-id          - (required) unique identifier; only alphanumeric, ., -,
                       and _ allowed
  --display-name     - user-readable display name (may contain i18n characters)
  --description      - user-readable description (may contain i18n characters)
  --note             - adds/updates/deletes notes to programmatically identify
                       the resource; key-value pairs must be separated by an
                       equal sign (e.g. key=value); multiple notes can be
                       changed by specifying this option multiple times; notes
                       are deleted by specifying "" as the value
  --auto-publish     - if "true", on each successful sync the repository will
                       automatically be published; if "false" content will only
                       be available after manually publishing the repository;
                       defaults to "true"
  --redirect-url     - The URL that will be used when generating the redirect
                       map for connecting the docker API to the location the
                       content is stored. The value defaults to
                       https://<server_name_from_pulp_server.conf>/pulp/docker/<
                       repo_name>.
  --protected        - if "true" requests for this repo will be checked for an
                       entitlement certificate authorizing the server url for
                       this repository; if "false" no authorization checking
                       will be done.
  --repo-registry-id - the name that will be used for this repository in the
                       Docker registry. If not specified, the repo id will be
                       used
  --enable-v1        - Enable sync of v1 API. defaults to "true"
  --enable-v2        - Enable sync of v2 API. defaults to "true"

Synchronization
  --feed          - URL for the upstream docker index, not including repo name
  --validate      - if "true", the size and checksum of each synchronized file
                    will be verified against the repo metadata
  --upstream-name - name of the upstream repository

Feed SSL
  --feed-ca-cert    - full path to the CA certificate that should be used to
                      verify the external repo server's SSL certificate
  --verify-feed-ssl - if "true", the feed's SSL certificate will be verified
                      against the feed_ca_cert
  --feed-cert       - full path to the certificate to use for authorization when
                      accessing the external feed
  --feed-key        - full path to the private key for feed_cert

Feed Proxy
  --proxy-host - proxy server url to use
  --proxy-port - port on the proxy server to make requests
  --proxy-user - username used to authenticate with the proxy server
  --proxy-pass - password used to authenticate with the proxy server

Basic Authentication
  --basicauth-user - username used to authenticate with sync location via HTTP
                     basic auth
  --basicauth-pass - password used to authenticate with sync location via HTTP
                     basic auth

Throttling
  --max-downloads - maximum number of downloads that will run concurrently
  --max-speed     - maximum bandwidth used per download thread, in bytes/sec,
                    when synchronizing the repo

This isn't quite right: --enable-v1 - Enable sync of v1 API. defaults to "true". In reality, v1 content isn't synced by default. The help text should state defaults to "false". This seems to be the offending line of code.

I can reproduce on at least Pulp 2.12, 2.13 and 2.14.

Thanks for @ipanova for her help in troubleshooting this bug.

Associated revisions

Revision 2b3be379 View on GitHub
Added by mansari over 2 years ago

docker repo create --help states v1 content is synced by default

v1 content isn't synced by default. Hence, the help text should state defaults to "false"

closes #2724

Revision 2b3be379 View on GitHub
Added by mansari over 2 years ago

docker repo create --help states v1 content is synced by default

v1 content isn't synced by default. Hence, the help text should state defaults to "false"

closes #2724

Revision 2b3be379 View on GitHub
Added by mansari over 2 years ago

docker repo create --help states v1 content is synced by default

v1 content isn't synced by default. Hence, the help text should state defaults to "false"

closes #2724

Revision 2b3be379 View on GitHub
Added by mansari over 2 years ago

docker repo create --help states v1 content is synced by default

v1 content isn't synced by default. Hence, the help text should state defaults to "false"

closes #2724

History

#1 Updated by Ichimonji10 almost 3 years ago

  • Description updated (diff)

#2 Updated by Ichimonji10 almost 3 years ago

  • Subject changed from `pulp-adminn docker repo create --help` states v1 content is synced by default to `pulp-admin docker repo create --help` states v1 content is synced by default

#3 Updated by ttereshc almost 3 years ago

  • Triaged changed from No to Yes
  • Tags Easy Fix added

#4 Updated by mansari over 2 years ago

  • Assignee set to mansari

#5 Updated by mansari over 2 years ago

  • Status changed from NEW to POST

#7 Updated by mansari over 2 years ago

  • Status changed from POST to MODIFIED

#8 Updated by pcreech over 2 years ago

  • Platform Release set to 2.14.0

#9 Updated by pcreech over 2 years ago

  • Status changed from MODIFIED to ON_QA

#10 Updated by Ichimonji10 over 2 years ago

  • Verified changed from No to Yes

#11 Updated by kdelee@redhat.com over 2 years ago

Verified this fix on Fedora 25 with the 2.14 beta (2) as a part of the 2.14 Beta Test Day

$ rpm -qa | grep pulp

python-pulp-bindings-2.14.0-0.1.beta.fc25.noarch
pulp-ostree-admin-extensions-1.3.0-0.3.rc.git.1.3a770cd.fc25.noarch
python-pulp-docker-common-3.0.0-0.1.beta.fc25.noarch
pulp-deb-plugins-1.5.2-0.2.beta.fc25.noarch
python-pulp-deb-common-1.5.2-0.2.beta.fc25.noarch
pulp-puppet-admin-extensions-2.14.0-0.3.rc.git.1.12bf98c.fc25.noarch
python-pulp-rpm-common-2.14.0-0.1.beta.fc25.noarch
python-pulp-python-common-2.0.1-0.1.beta.fc25.noarch
pulp-selinux-2.14.0-0.3.rc.git.1.b8a44dd.fc25.noarch
pulp-deb-admin-extensions-1.5.2-0.2.beta.fc25.noarch
python-pulp-repoauth-2.14.0-0.1.beta.fc25.noarch
pulp-puppet-plugins-2.14.0-0.3.rc.git.1.12bf98c.fc25.noarch
pulp-rpm-admin-extensions-2.14.0-0.3.rc.git.1.5746bbf.fc25.noarch
python-pulp-oid_validation-2.14.0-0.1.beta.fc25.noarch
pulp-admin-client-2.14.0-0.3.rc.git.1.b8a44dd.fc25.noarch
pulp-python-plugins-2.0.1-0.3.rc.git.1.1d5b1c8.fc25.noarch
python-pulp-client-lib-2.14.0-0.1.beta.fc25.noarch
python-pulp-streamer-2.14.0-0.1.beta.fc25.noarch
pulp-docker-plugins-3.0.0-0.3.rc.git.1.5149268.fc25.noarch
python-pulp-common-2.14.0-0.1.beta.fc25.noarch
pulp-ostree-plugins-1.3.0-0.3.rc.git.1.3a770cd.fc25.noarch
python-pulp-puppet-common-2.14.0-0.1.beta.fc25.noarch
python-pulp-ostree-common-1.3.0-0.1.beta.fc25.noarch
pulp-server-2.14.0-0.3.rc.git.1.b8a44dd.fc25.noarch
pulp-docker-admin-extensions-3.0.0-0.3.rc.git.1.5149268.fc25.noarch
pulp-python-admin-extensions-2.0.1-0.3.rc.git.1.1d5b1c8.fc25.noarch
pulp-rpm-plugins-2.14.0-0.3.rc.git.1.5746bbf.fc25.noarch

#12 Updated by pcreech over 2 years ago

  • Status changed from ON_QA to CLOSED - CURRENTRELEASE

#13 Updated by bmbouter 11 months ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF