Project

Profile

Help

Task #2246

Document why Pulp 3 is Python 3 only

Added by jcline@redhat.com about 3 years ago. Updated 6 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
Start date:
Due date:
% Done:

100%

Platform Release:
Blocks Release:
Backwards Incompatible:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation
QA Contact:
Complexity:
Smash Test:
Verified:
No
Verification Required:
No
Sprint:

Description

Pulp 3 has chosen to only support Python 3. We should include a short paragraph in our documentation explaining why this is the case.

It really just needs to say something along the lines of

  • Python 2 is EOL and support for security updates is going away very soon.
  • Many distributions are dropping Python 2
  • Many libraries are dropping Python 2
  • It provides many features that makes our lives easier

Associated revisions

Revision fc3fb7b7 View on GitHub
Added by Jeremy Cline about 3 years ago

Document Pulp 3 only supports Python 3

closes #2246

Revision fc3fb7b7 View on GitHub
Added by Jeremy Cline about 3 years ago

Document Pulp 3 only supports Python 3

closes #2246

Revision fc3fb7b7 View on GitHub
Added by Jeremy Cline about 3 years ago

Document Pulp 3 only supports Python 3

closes #2246

History

#1 Updated by jcline@redhat.com about 3 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jcline@redhat.com

#3 Updated by Anonymous about 3 years ago

  • Status changed from ASSIGNED to MODIFIED
  • % Done changed from 0 to 100

#4 Updated by semyers about 3 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

#5 Updated by daviddavis 6 months ago

  • Sprint/Milestone set to 3.0

#6 Updated by bmbouter 6 months ago

  • Tags deleted (Pulp 3)

Please register to edit this issue

Also available in: Atom PDF