Project

Profile

Help

Issue #2231

Vagrant up is missing PyYaml package

Added by bmbouter about 4 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

On the 3.0-dev branch when I vagrant up using machinery provided by the devel/devel repo I am missing PyYaml. To reproduce:

1) Vagrant up with everything using up-to-date 3.0-dev branches
2) django-admin shell_plus
3) Observe the following traceback

[vagrant@dev ~]$ django-admin 
Traceback (most recent call last):
  File "/usr/bin/django-admin", line 9, in <module>
    load_entry_point('Django', 'console_scripts', 'django-admin')()
  File "/usr/lib/python2.7/site-packages/Django-1.8.14-py2.7.egg/django/core/management/__init__.py", line 354, in execute_from_command_line
    utility.execute()
  File "/usr/lib/python2.7/site-packages/Django-1.8.14-py2.7.egg/django/core/management/__init__.py", line 303, in execute
    settings.INSTALLED_APPS
  File "/usr/lib/python2.7/site-packages/Django-1.8.14-py2.7.egg/django/conf/__init__.py", line 48, in __getattr__
    self._setup(name)
  File "/usr/lib/python2.7/site-packages/Django-1.8.14-py2.7.egg/django/conf/__init__.py", line 44, in _setup
    self._wrapped = Settings(settings_module)
  File "/usr/lib/python2.7/site-packages/Django-1.8.14-py2.7.egg/django/conf/__init__.py", line 92, in __init__
    mod = importlib.import_module(self.SETTINGS_MODULE)
  File "/usr/lib64/python2.7/importlib/__init__.py", line 37, in import_module
    __import__(name)
  File "/home/vagrant/devel/pulp/platform/pulp/platform/settings.py", line 17, in <module>
    import yaml
ImportError: No module named yaml

If I install PyYaml with the following command the error goes away:

sudo dnf install PyYAML -y

Associated revisions

Revision fe449d63 View on GitHub
Added by Jeremy Cline about 4 years ago

Add PyYAML to the dependency list for platform

Pulp's platform package depends on PyYAML, so it should declare it in the setup.py.

fixes #2231

Revision fe449d63 View on GitHub
Added by Jeremy Cline about 4 years ago

Add PyYAML to the dependency list for platform

Pulp's platform package depends on PyYAML, so it should declare it in the setup.py.

fixes #2231

History

#1 Updated by bmbouter about 4 years ago

How many places does this need to be fixed? All of these?

  • The spec file as a dependency?
  • The pulp.platform setup.py as a python dependency?
  • An dependency to be installed by ansible or does this parse the spec files?

#2 Updated by amacdona@redhat.com about 4 years ago

  • Triaged changed from No to Yes

#3 Updated by jcline@redhat.com about 4 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to jcline@redhat.com

#4 Updated by jcline@redhat.com about 4 years ago

  • Status changed from ASSIGNED to POST

#5 Updated by jcline@redhat.com about 4 years ago

  • Status changed from POST to CLOSED - CURRENTRELEASE

I'm going to close this as CURRENTRELEASE because it's pretty much a development environment issue at the moment.

#6 Updated by bmbouter about 4 years ago

When running vagrant, during the `pulp-dev -I` portion I get the following error:

Installed /home/vagrant/devel/pulp/platform
Processing dependencies for pulp-platform==3.0a1
Searching for PyYAML
Reading https://pypi.python.org/simple/PyYAML/
Best match: PyYAML 3.12
Downloading https://pypi.python.org/packages/6b/f0/a0250248ea260d55748fff586d89a32afbb22656f4498b08d2636a48d4ec/PyYAML-3.12.zip#md5=aa5e762e79b19bb80d
bcf04f82178832
Processing PyYAML-3.12.zip
Writing /tmp/easy_install-_60iFk/PyYAML-3.12/setup.cfg
Running PyYAML-3.12/setup.py -q bdist_egg --dist-dir /tmp/easy_install-_60iFk/PyYAML-3.12/egg-dist-tmp-HxMEVl
build/temp.linux-x86_64-2.7/check_libyaml.c:2:18: fatal error: yaml.h: No such file or directory
 #include <yaml.h>
                  ^
compilation terminated.

I'm going to fix this, but I want to post it here since its related.

#7 Updated by bmbouter about 4 years ago

Actually even when that error is shown PyYAML seems to work fine for me so I'm going to do nothing for now and focus on what I was doing.

#8 Updated by jcline@redhat.com about 4 years ago

The PyYAML package can make use of the C YAML library for performance reasons, but falls back to a pure Python implementation if it fails to compile the extensions. In this case, it lacks the yaml header file, which is probably provided by libyaml-devel. It doesn't really matter one way or the other since we already pull in GCC (which is the heaviest build dependency, I imagine), but we aren't using YAML for anything big.

#9 Updated by bmbouter about 4 years ago

Oh that makes sense then why I saw he fatal error, but the module seemed to work well for me. Thanks for the info.

#11 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF