Project

Profile

Help

Issue #2121

closed

Requires: selinux-policy is broken in spec files

Added by milligana over 7 years ago. Updated almost 5 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.9.0
Platform Release:
2.9.3
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

In pulp.spec, we have this travesty:

%define selinux_policyver %(sed -e's,.*selinux-policy-\\([^/]*\\)/.*,\\1,'/usr/share/selinux/devel/policyhelp 2> /dev/null)

Which supposedly fires up xdg (ie X in mock) and groks the policy version out of a help browser footer.

But it doesn't actually work in my setup as there does not seem to be a version shipped in selinux policy help ...

How about something less ambitious - perhaps like:

%define selinux_policyver %(rpm --qf "%{version}" -q selinux-policy)

I bring this up because I can't actually build vanilla pulp from src as you ship it.

Also available in: Atom PDF