Project

Profile

Help

Issue #2084

updating to --auto-publish false has unexpected result

Added by dkliban@redhat.com over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Docker:
master
Platform Release:
Target Release - Docker:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Hard to tell if auto-publish is set to false now or not. It's both true and false. Am I reading this right?


pulp-admin docker repo create --repo-id docker2 --feed http://localhost:5000 --upstream-name ubuntu
pulp-admin docker repo update --repo-id docker2 --auto-publish false
pulp-admin docker repo list --details --repo-id docker2

[vagrant@dev devel]$ pulp-admin docker repo list --details --repo-id docker2
+----------------------------------------------------------------------+
                          Docker Repositories
+----------------------------------------------------------------------+

Id:                   docker2
Display Name:         None
Description:          None
Content Unit Counts:
Notes:
Scratchpad:
Importers:
  Config:
    Feed:          http://localhost:5000
    Upstream Name: ubuntu
  Id:               docker_importer
  Importer Type Id: docker_importer
  Last Sync:        None
  Repo Id:          docker2
  Scratchpad:       None
Distributors:
  Auto Publish:         True
  Config:
    Auto Publish: False
  Distributor Type Id:  docker_distributor_web
  Id:                   docker_web_distributor_name_cli
  Last Override Config:
  Last Publish:         None
  Last Updated:         2016-07-19T18:21:11Z
  Repo Id:              docker2
  Scratchpad:
  Auto Publish:         False
  Config:
  Distributor Type Id:  docker_distributor_export
  Id:                   docker_export_distributor_name_cli
  Last Override Config:
  Last Publish:         None
  Last Updated:         2016-07-19T17:59:36Z
  Repo Id:              docker2
  Scratchpad:

if I create the repo with it alreaddy set to false I get

[vagrant@dev devel]$ pulp-admin docker repo create --repo-id docker2 --feed http://localhost:5000 --upstream-name ubuntu --auto-publish false
Repository [docker2] successfully created

[vagrant@dev devel]$ pulp-admin docker repo list --details --repo-id docker2
+----------------------------------------------------------------------+
                          Docker Repositories
+----------------------------------------------------------------------+

Id:                   docker2
Display Name:         None
Description:          None
Content Unit Counts:
Notes:
Scratchpad:
Importers:
  Config:
    Feed:          http://localhost:5000
    Upstream Name: ubuntu
  Id:               docker_importer
  Importer Type Id: docker_importer
  Last Sync:        None
  Repo Id:          docker2
  Scratchpad:       None
Distributors:
  Auto Publish:         False
  Config:
  Distributor Type Id:  docker_distributor_web
  Id:                   docker_web_distributor_name_cli
  Last Override Config:
  Last Publish:         None
  Last Updated:         2016-07-19T18:22:13Z
  Repo Id:              docker2
  Scratchpad:
  Auto Publish:         False
  Config:
  Distributor Type Id:  docker_distributor_export
  Id:                   docker_export_distributor_name_cli
  Last Override Config:
  Last Publish:         None
  Last Updated:         2016-07-19T18:22:13Z
  Repo Id:              docker2
  Scratchpad:

Related issues

Is duplicate of Docker Support - Issue #2078: Updating auto-publish value in the repo update does not influence the behaviour.CLOSED - WONTFIX<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by dkliban@redhat.com over 5 years ago

  • Version - Docker set to master

#3 Updated by ttereshc over 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#4 Updated by ttereshc over 5 years ago

  • Is duplicate of Issue #2078: Updating auto-publish value in the repo update does not influence the behaviour. added

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF