Project

Profile

Help

Issue #2003

closed

Pulp will not sync RPM files hosted using "packagecloud".

Added by liger almost 6 years ago. Updated about 3 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.8.4
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Packagecloud is an increasingly popular package repo hosting service. It uses Amazon AWS storage at the backend. Tools such as "yum" and "reposync" have no issue with packagecloud Yum repos, but Pulp will not synchronize RPMs stored in packagecloud yum repos.

Pulp version: 2.8.4
Steps to reproduce:

pulp-admin rpm repo create --repo-id test-gitlab_ce --relative-url test-gitlab_ce --feed https://packages.gitlab.com/gitlab/gitlab-ce/el/7/x86_64 --serve-http true --remove-missing true --retain-old-count 2 --download-policy immediate
pulp-admin rpm repo sync run --repo-id test-gitlab_ce
pulp-admin rpm repo publish run --repo-id test-gitlab_ce

Expected result:

Three RPMs synchronized from repo specified by feed.

Actual result:

Zero RPMS synchronized.

As mentioned "reposync" can synchronize the repo without issue and "yum" can use the repo directly, so it is obviously a valid Yum repo. Pulp should be able to synchronize these repos!


Related issues

Is duplicate of Pulp - Issue #1287: Repo sync failing with KeyErrorCLOSED - CURRENTRELEASEttereshcActions
Actions #1

Updated by ipanova@redhat.com almost 6 years ago

  • Is duplicate of Issue #1287: Repo sync failing with KeyError added
Actions #2

Updated by ipanova@redhat.com almost 6 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
Actions #3

Updated by bmbouter about 3 years ago

  • Tags Pulp 2 added

Also available in: Atom PDF