Project

Profile

Help

Issue #1981

unnecessary pulp error on puppet repo sync

Added by jomitsch@redhat.com over 5 years ago. Updated about 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.8.3
Platform Release:
2.11.1
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Sprint 13
Quarter:

Description

When syncing a puppet repo, this error sometimes shows

pulp_puppet.plugins.importers.directory:ERROR: Fetch URL: https://qeblade36.rhq.lab.eng.bos.redhat.com/pulp/puppet/Default_Organization-Library-puppet_cv/PULP_MANIFEST failed"

The sync will still be successful and the error will show, it appears it first tries a directory-sync (over http?) and when it fails to find the PULP_MANIFEST it falls back to the puppet forge sync

I found this when syncing the same puppet module to two different repos (the same procedure described here https://pulp.plan.io/issues/1937 )

Attached is a puppet module tarball that may be useful in reproducing

module.tar.gz (29.8 KB) module.tar.gz jomitsch@redhat.com, 06/07/2016 05:19 PM

Checklist

Associated revisions

Revision 285fa225 View on GitHub
Added by ipanova@redhat.com almost 5 years ago

1981 - Unnecessary pulp error on puppet repo sync.

closes #1981 https://pulp.plan.io/issues/1981

History

#1 Updated by bmbouter over 5 years ago

  • Checklist item reword the message to not make it read as a failure since it is optional added
  • Checklist item Log at the info level instead of the error level added

I'm familiar with this, and this is a valid report. I propose we do 2 things which I put on here as checklist items.

#3 Updated by ipanova@redhat.com over 5 years ago

  • Project changed from Pulp to Puppet Support

#4 Updated by amacdona@redhat.com over 5 years ago

  • Severity changed from 2. Medium to 1. Low
  • Triaged changed from No to Yes
  • Tags Easy Fix added

#5 Updated by ipanova@redhat.com almost 5 years ago

  • Sprint/Milestone set to 31

#6 Updated by ipanova@redhat.com almost 5 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com

#7 Updated by mhrivnak almost 5 years ago

  • Status changed from ASSIGNED to POST

#9 Updated by ipanova@redhat.com almost 5 years ago

  • Status changed from POST to MODIFIED

#10 Updated by semyers almost 5 years ago

  • Platform Release set to 2.11.1

#11 Updated by semyers almost 5 years ago

  • Status changed from MODIFIED to 5

#12 Updated by semyers almost 5 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#13 Updated by bmbouter over 3 years ago

  • Sprint set to Sprint 13

#14 Updated by bmbouter over 3 years ago

  • Sprint/Milestone deleted (31)

#15 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

#16 Updated by JudyMraz about 2 years ago

  • File clipboard-201908261221-7tlwr.png added

#17 Updated by bmbouter about 2 years ago

  • File deleted (clipboard-201908261221-7tlwr.png)

Please register to edit this issue

Also available in: Atom PDF