Project

Profile

Help

Issue #1937

Syncing a puppet module with the same content as a different repo results in no content

Added by jomitsch@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.8.3
Platform Release:
2.8.5
OS:
CentOS 7
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Found this when doing capsule syncs in Katello (pulp to pulp sync) but also was able to reproduce on a single pulp server.

The issue:
A puppet module is uploaded to puppet repo A and then when the same puppet module is uploaded to puppet module B (both using the same feed), puppet module B has no content.

puppet repo B, there is no content
/var/lib/pulp/published/puppet/https/repos/Default_Organization-prod1-pup1

To reproduce:
attached is a puppet module tarball to make it easier to reproduce
1) Create a puppet repo with the feed pointed at the tarball, notice that the relevant content shows in the repo's filepath
2) Create a puppet repo with the same feed, notice that the relevant content does not show in this repos filepath

module.tar.gz (29.8 KB) module.tar.gz jomitsch@redhat.com, 05/23/2016 05:12 PM

Associated revisions

Revision 577bd409 View on GitHub
Added by Jeremy Cline over 4 years ago

Forge importer now queries the repo units instead of all units

This commit fixes a problem where the Forge importer would skip importing units into a repository if the unit already existed in Pulp. This patch does not address the problem that the importer will download a module even if it already exists within Pulp; that issue is being tracked in https://pulp.plan.io/issues/1943

fixes #1937

Revision 1cb6c874 View on GitHub
Added by Jeremy Cline over 4 years ago

Forge importer now queries the repo units instead of all units

This commit fixes a problem where the Forge importer would skip importing units into a repository if the unit already existed in Pulp. This patch does not address the problem that the importer will download a module even if it already exists within Pulp; that issue is being tracked in https://pulp.plan.io/issues/1943

fixes #1937

History

#2 Updated by mhrivnak over 4 years ago

Are you describing an upload, or a sync? Uploads usually don't use a "feed", but syncs do.

If you're describing a sync, I assume you're using a PULP_MANIFEST file in the directory?

#3 Updated by jomitsch@redhat.com over 4 years ago

mhrivnak wrote:

Are you describing an upload, or a sync? Uploads usually don't use a "feed", but syncs do.

If you're describing a sync, I assume you're using a PULP_MANIFEST file in the directory?

Yes, 'upload' may have been misleading, I am describing creating two repos and syncing them

#4 Updated by jcline@redhat.com over 4 years ago

  • Status changed from NEW to POST
  • Assignee set to jcline@redhat.com

#7 Updated by jcline@redhat.com over 4 years ago

  • Triaged changed from No to Yes

#8 Updated by Anonymous over 4 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#9 Updated by jcline@redhat.com over 4 years ago

  • Platform Release set to 2.8.5

The associated revisions looks weird because I accidentally merged this into master rather than 2.8-dev, so I cherry-picked it and merged-forward. The commit you should use to see if a branch/tag contains this fix is 1cb6c874e0c0c09200053126d853773b6708b62f

#10 Updated by semyers over 4 years ago

  • Status changed from MODIFIED to 5

#11 Updated by semyers over 4 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#12 Updated by mhrivnak over 4 years ago

  • Project changed from Pulp to Puppet Support

#14 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF