Project

Profile

Help

Issue #1946

pulp-admin rpm repo update --relative-url doesn't clean up after itself

Added by kfiresmith over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
1. Low
Version:
2.8.3
Platform Release:
OS:
RHEL 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Folks,
I've discovered that re-organizing pulp RPM repos is not as easy as it would seem using the 'rpm repo update' function. It appears that cruft is left behind in the form of a directory structure with a single file called 'listing' in each segment of said directory path.

Thus if I have a repository published at /pulp/repos/IBM/7/7Server/x86_64/, and I use 'pulp-admin rpm repo update --repo-id=IBM-server-7 --relative-url=thirdparty/IBM', the new directory structure is published as you would expect at /pulp/repos/thirdparty/IBM, but there is an entire (mostly) empty folder structure left behind at /pulp/repos/IBM.


Related issues

Is duplicate of RPM Support - Issue #522: Changing relative URL doesn't remove old URL.CLOSED - WONTFIX<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by ipanova@redhat.com over 4 years ago

  • Is duplicate of Issue #522: Changing relative URL doesn't remove old URL. added

#2 Updated by ipanova@redhat.com over 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF