Project

Profile

Help

Issue #522

Changing relative URL doesn't remove old URL.

Added by akegata@gmail.com over 5 years ago. Updated over 1 year ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.4.0
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Description of problem:
If a repo is published over http/https and the relative URL is later changed and the repo republished, the old relative URL still exists (although not everything published it still there, seems like only the listing files and the folders are left).

Version-Release number of selected component (if applicable):
2.4.0

How reproducible:
Easily

Steps to Reproduce:
1. Create repo with relative URL RHEL
2. pulp-admin rpm repo publish run --repo-id RHEL
3. pulp-admin rpm repo update --relative-url RedHat --repo-id RHEL
4. pulp-admin rpm repo publish run --repo-id RHEL
5. Check the available folders at <server>/pulp/repos

Actual results:
Both folders RHEL and RedHat exist.

Expected results:
Only the RedHat folder should remain.

Additional info:

+ This bug was cloned from Bugzilla Bug #1141252 +


Related issues

Related to Pulp - Issue #671: On sync and delete, relative urls conflict with relative urls of deleted reposCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Has duplicate Pulp - Issue #1946: pulp-admin rpm repo update --relative-url doesn't clean up after itselfCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by amacdona@redhat.com over 5 years ago

  • Related to Issue #671: On sync and delete, relative urls conflict with relative urls of deleted repos added

#2 Updated by amacdona@redhat.com over 5 years ago

  • Status changed from NEW to MODIFIED
  • Assignee set to amacdona@redhat.com

Fixed, along with 671 here:

https://github.com/pulp/pulp_rpm/pull/648

#3 Updated by bmbouter over 5 years ago

  • Severity changed from Medium to 2. Medium

#4 Updated by dkliban@redhat.com over 5 years ago

  • Status changed from MODIFIED to 5
  • Platform Release set to 2.6.1

#5 Updated by pthomas@redhat.com over 5 years ago

  • Status changed from 5 to 6

verified
[root@qe-blade-13 ~]# rpm -qa pulp-server
pulp-server-2.6.1-1.el6.noarch
[root@qe-blade-13 ~]#

#6 Updated by chandlermelton about 5 years ago

  • Status changed from 6 to NEW

I am seeing this issue using 2.6.3-1.

If I update a relative-url then republish the repo, the old directory is still there, but empty.

#7 Updated by bmbouter about 5 years ago

  • Triaged changed from Yes to No

Sending this back to triage to match its NEW state.

#8 Updated by mhrivnak about 5 years ago

  • Triaged changed from No to Yes

#9 Updated by amacdona@redhat.com about 5 years ago

  • Assignee deleted (amacdona@redhat.com)
  • Platform Release changed from 2.6.1 to 2.6.5

This one was not fixed by https://github.com/pulp/pulp_rpm/pull/648 as I originally thought it would be, but it can be fixed using the same machinery. It just needs to be called on update as well as delete.

#10 Updated by dkliban@redhat.com almost 5 years ago

  • Platform Release changed from 2.6.5 to 2.6.6

#11 Updated by dkliban@redhat.com almost 5 years ago

  • Platform Release deleted (2.6.6)

#12 Updated by jlambert121 over 4 years ago

This is still an issue in 2.8.2 as well.

#13 Updated by ipanova@redhat.com over 4 years ago

  • Has duplicate Issue #1946: pulp-admin rpm repo update --relative-url doesn't clean up after itself added

#14 Updated by kfiresmith over 4 years ago

+1 - still a problem in 2.8.3. I'd love to see this get sorted because I'm not really sure how to clean it up manually in the mean time.

#15 Updated by Poil about 2 years ago

Same problem with 2.16.1

#16 Updated by bmbouter over 1 year ago

  • Status changed from NEW to CLOSED - WONTFIX

Pulp 2 is approaching maintenance mode, and this Pulp 2 ticket is not being actively worked on. As such, it is being closed as WONTFIX. Pulp 2 is still accepting contributions though, so if you want to contribute a fix for this ticket, please reopen or comment on it. If you don't have permissions to reopen this ticket, or you want to discuss an issue, please reach out via the developer mailing list.

#17 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF