Project

Profile

Help

Story #1906

Consumers are added to group but not bound to group repos

Added by lhorace over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Pulp 2
Sprint:
Quarter:

Description

Hello,

It would be a great 'ease-of-use' feature to have consumers in a group automatically bound to the consumer group repos when they are added to the consumer group. I tagged documentation as it wasn't clear that consumers must be added to the consumer group first then later bound repos to that consumer group. This isn't a bother on a first deployment, however when you register a new consumer within a group in the future, one would have to go through the additional task of querying what repos are bound to that consumer group. Which in some cases can be many and manually binding each repo at the consumer level.

Regards,
Horace


Related issues

Is duplicate of Pulp - Story #167: [RFE] new consumers do not auto subscribe to already bound consumer group reposCLOSED - WONTFIX

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by lhorace over 5 years ago

A workaround for this issue is probably to add a list of commands to a script to be excuted every time a consumer is registered to a consumer group.

#!/bin/bash

pulp-admin rpm consumer group bind --consumer-group-id=group_1 --repo-id=repo_1
pulp-admin rpm consumer group bind --consumer-group-id=group_1 --repo-id=repo_2
pulp-admin rpm consumer group bind --consumer-group-id=group_1 --repo-id=repo_3
pulp-admin rpm consumer group bind --consumer-group-id=group_1 --repo-id=repo_4
pulp-admin rpm consumer group bind --consumer-group-id=group_1 --repo-id=repo_5

Regards

#2 Updated by dkliban@redhat.com over 5 years ago

  • Tracker changed from Issue to Story
  • Groomed set to No
  • Sprint Candidate set to No
  • Tags deleted (Documentation)

#3 Updated by ipanova@redhat.com over 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE
  • Tags Documentation added

#4 Updated by ipanova@redhat.com over 5 years ago

  • Is duplicate of Story #167: [RFE] new consumers do not auto subscribe to already bound consumer group repos added

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF