Project

Profile

Help

Task #1874

Plan User/Auth system for 3.0

Added by mhrivnak over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

The user/auth system in 2.y has many opportunities for improvement. Porting it from mongodb to postgres might take about the same effort as standardizing on django's auth.

There are many advantages to using django's auth, including having less custom code, and being able to easily use complimentary apps like django-admin.

https://docs.djangoproject.com/es/1.9/topics/auth/

This task is to investigate django's auth, whether it meets our needs (it may need to be extended for path-based authz), and how it would affect current use cases. As a bonus, investigate how it could integrate with freeipa.


Related issues

Related to Pulp - Task #1803: Plan replacement of mongodb with postgresCLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Related to Pulp - Task #1873: Plan REST API for 3.0CLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Task #2090: Create a plan for user/auth in 3.0CLOSED - CURRENTRELEASE

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mhrivnak over 4 years ago

  • Related to Task #1803: Plan replacement of mongodb with postgres added

#2 Updated by mhrivnak over 4 years ago

  • Related to Task #1873: Plan REST API for 3.0 added

#3 Updated by mhrivnak over 4 years ago

  • Sprint Candidate changed from Yes to No

#4 Updated by bmbouter about 4 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

This is a duplicate of #2090 which was filed much later but has a lot of discussion on it. I'm going to close this one as a duplicate.

#5 Updated by bmbouter about 4 years ago

  • Is duplicate of Task #2090: Create a plan for user/auth in 3.0 added

#6 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF