Project

Profile

Help

Issue #1767

Errors when synchronizing from a mirror list

Added by gehogan3 over 5 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.7.1
Platform Release:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

When synchronizing the EPEL repo from http://download.fedoraproject.org/pub/epel/7/x86_64/ to my local pulp server, there was at least one server with connectivity problems. This caused several packages not to download and the subsequent publish process failed. The http repo would only list RPMs up to the failed package. (i.e. if it failed on the apbs-tools rpm, then none of the packages which fell alphabetically after that were published.) If a reliable site is chosen (i.e. kernel.org), the entire repository downloads and publishes without error.

The command used to create the repo that was failing:

pulp-admin rpm repo update --repo-id=centos7-x86_64_epel --display-name="Centos7 - EPEL" --feed=http://download.fedoraproject.org/pub/epel/7/x86_64/ --validate=true

As I mentioned, changing the feed to: --feed=http://mirrors.kernel.org/fedora-epel/7/x86_64/
Fixed the problem.

/var/log/messages did reflect problems with some of the mirrors:

Mar 10 16:18:52 admin-1-lp-202 pulp: requests.packages.urllib3.connectionpool:INFO: Resetting dropped connection: mirror.cs.princeton.edu
Mar 10 16:18:52 admin-1-lp-202 pulp: nectar.downloaders.threaded:WARNING: Connection Error - http://download.fedoraproject.org/pub/epel/7/x86_64/a/aqbanking-devel-5.5.1-1.el7.x86_64.rpm could not be reached.


Related issues

Is duplicate of Nectar - Issue #1210: ConnectionError - BadStatusLine during repo syncCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by gehogan3 over 5 years ago

When I said: "there was at least one server with connectivity problems" I was referring to one of the mirrors.

#2 Updated by ipanova@redhat.com over 5 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#3 Updated by ipanova@redhat.com over 5 years ago

  • Is duplicate of Issue #1210: ConnectionError - BadStatusLine during repo sync added

#4 Updated by jcline@redhat.com over 5 years ago

Hi gehogan3, thanks for the report!

We believe this has been fixed in nectar-1.5.0, but there's also a patch that has been backported to nectar-1.3.3 (which is probably the version you're using). The patch is attached to https://bugzilla.redhat.com/show_bug.cgi?id=1248167. If you try it out and run into problems, please let us know!

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF