Project

Profile

Help

Issue #1732

Remove missing test case is failing on EL6

Added by dkliban@redhat.com over 4 years ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
2.8.1
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

I am seeing the following traceback when running RemoveMissingTestCase:

Traceback (most recent call last):
  File "/home/jenkins/workspace/pulp-smash-runner/pulp-smash/pulp_smash/tests/rpm/api_v2/test_remove_unit.py", line 104, in setUpClass
    cls.responses['second sync'] = _sync_repo(cls.cfg, hrefs[1])
  File "/home/jenkins/workspace/pulp-smash-runner/pulp-smash/pulp_smash/tests/rpm/api_v2/test_remove_unit.py", line 40, in _sync_repo
    {'override_config': {}}
  File "/home/jenkins/workspace/pulp-smash-runner/pulp-smash/pulp_smash/api.py", line 269, in post
    return self.request('POST', url, json=json, **kwargs)
  File "/home/jenkins/workspace/pulp-smash-runner/pulp-smash/pulp_smash/api.py", line 295, in request
    requests.request(method, **request_kwargs),
  File "/home/jenkins/workspace/pulp-smash-runner/pulp-smash/pulp_smash/api.py", line 112, in safe_handler
    _handle_202(server_config, response)
  File "/home/jenkins/workspace/pulp-smash-runner/pulp-smash/pulp_smash/api.py", line 89, in _handle_202
    _check_tasks(tasks)
  File "/home/jenkins/workspace/pulp-smash-runner/pulp-smash/pulp_smash/api.py", line 79, in _check_tasks
    raise exceptions.TaskReportError(msg)
TaskReportError: Task report /pulp/api/v2/tasks/cc7f6f89-d5d7-4fd0-9863-657ae080a5d6/ contains a error: {u'code': u'PLP0000', u'data': {}, u'description': u'Importer indicated a failed response', u'sub_errors': []}
Full task report: {u'exception': None, u'task_type': u'pulp.server.managers.repo.sync.sync', u'_href': u'/pulp/api/v2/tasks/cc7f6f89-d5d7-4fd0-9863-657ae080a5d6/', u'task_id': u'cc7f6f89-d5d7-4fd0-9863-657ae080a5d6', u'tags': [u'pulp:repository:9748039d-24e8-4a78-861b-91885a6c23f1', u'pulp:action:sync'], u'finish_time': u'2016-03-01T16:05:55Z', u'_ns': u'task_status', u'start_time': u'2016-03-01T16:05:50Z', u'traceback': u'Traceback (most recent call last):\n  File "/usr/lib/python2.6/site-packages/celery/app/trace.py", line 240, in trace_task\n    R = retval = fun(*args, **kwargs)\n  File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 473, in __call__\n    return super(Task, self).__call__(*args, **kwargs)\n  File "/usr/lib/python2.6/site-packages/pulp/server/async/tasks.py", line 103, in __call__\n    return super(PulpTask, self).__call__(*args, **kwargs)\n  File "/usr/lib/python2.6/site-packages/celery/app/trace.py", line 437, in __protected_call__\n    return self.run(*args, **kwargs)\n  File "/usr/lib/python2.6/site-packages/pulp/server/controllers/repository.py", line 807, in sync\n    raise pulp_exceptions.PulpExecutionException(_(\'Importer indicated a failed response\'))\nPulpExecutionException: Importer indicated a failed response\n', u'spawned_tasks': [], u'progress_report': {u'yum_importer': {u'content': {u'size_total': 0, u'items_left': 0, u'items_total': 0, u'state': u'FAILED', u'size_left': 0, u'details': {u'rpm_total': 0, u'rpm_done': 0, u'drpm_total': 0, u'drpm_done': 0}, u'error': u"[Errno 2] No such file or directory: u'/var/cache/pulp/reserved_resource_worker-1@rhel6-vanilla-np-qeos-78612/cc7f6f89-d5d7-4fd0-9863-657ae080a5d6/tmpGuwwPi/dfc5c7f7414400787ee1ba20e575040bbff84c513cfafbfe56bee8f6d5afae0c-comps.xml'", u'error_details': []}, u'comps': {u'state': u'NOT_STARTED'}, u'purge_duplicates': {u'state': u'NOT_STARTED'}, u'distribution': {u'items_total': 0, u'state': u'NOT_STARTED', u'error_details': [], u'items_left': 0}, u'errata': {u'state': u'NOT_STARTED'}, u'metadata': {u'state': u'FINISHED'}}}, u'queue': u'reserved_resource_worker-1@rhel6-vanilla-np-qeos-78612.dq', u'state': u'error', u'worker_name': u'reserved_resource_worker-1@rhel6-vanilla-np-qeos-78612', u'result': None, u'error': {u'code': u'PLP0000', u'data': {}, u'description': u'Importer indicated a failed response', u'sub_errors': []}, u'_id': {u'$oid': u'56d5bdde7ce15d471cdb71f2'}, u'id': u'56d5bdde7ce15d471cdb71f2'}

Main thing that stands out for now is

During the [Errno 2] No such file or directory: u'/var/cache/pulp/reserved_resource_worker-1@rhel6-vanilla-np-qeos-78612/cc7f6f89-d5d7-4fd0-9863-657ae080a5d6/tmpGuwwPi/dfc5c7f7414400787ee1ba20e575040bbff84c513cfafbfe56bee8f6d5afae0c-comps.xml'

Associated revisions

Revision 2a2b80dc View on GitHub
Added by pcreech over 4 years ago

Check for failed download in metadata downloader

Check for failed download in metadata downloader

closes #1732 https://pulp.plan.io/issues/1732

History

#1 Updated by dkliban@redhat.com over 4 years ago

I have now seen this error occur on F22 also. However, it has stopped appearing.

#2 Updated by dkliban@redhat.com over 4 years ago

I am seeing this again on F22 and EL7. I am investigating it.

#3 Updated by mhrivnak over 4 years ago

I strongly suspect the problem is that the act of downloading the metadata file is failing, but we aren't noticing that failure. When pulp tries to read the file from disk, only then does it notice that the file is missing.

This call: https://github.com/pulp/pulp_rpm/blob/019ed6cf7ea77d5dce1b19e39bbb307d776aeaa2/plugins/pulp_rpm/plugins/importers/yum/repomd/metadata.py#L202

does not check for failure. An example of what it should do:

https://github.com/pulp/pulp_rpm/blob/019ed6cf7ea77d5dce1b19e39bbb307d776aeaa2/plugins/pulp_rpm/plugins/importers/yum/repomd/metadata.py#L140

#4 Updated by mhrivnak over 4 years ago

  • Platform Release deleted (2.8.0)

#5 Updated by mhrivnak over 4 years ago

  • Platform Release set to 2.8.1
  • Triaged changed from No to Yes
  • Tags Easy Fix added

#6 Updated by pcreech over 4 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to pcreech

#7 Updated by pcreech over 4 years ago

  • Status changed from ASSIGNED to POST

#9 Updated by pcreech over 4 years ago

  • Status changed from POST to MODIFIED
  • % Done changed from 0 to 100

#10 Updated by semyers over 4 years ago

  • Status changed from MODIFIED to 5

#11 Updated by pthomas@redhat.com over 4 years ago

  • Status changed from 5 to 6

verified
pulp-smash test for unit removal are passing.

#12 Updated by semyers over 4 years ago

  • Status changed from 6 to CLOSED - CURRENTRELEASE

#14 Updated by bmbouter over 1 year ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF