Project

Profile

Help

Issue #1277

closed

Developer Setup Dependencies Documentation doesn't work with dnf

Added by pcreech about 7 years ago. Updated over 2 years ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Master
Platform Release:
2.6.4
OS:
Fedora 22
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Documentation, Easy Fix, Pulp 2
Sprint:
Quarter:

Description

Items four and five under the Dependencies section of the Developer Setup guide do not work with dnf.

/etc/dnf/dnf.conf specifies "clean_requiremnts_on_remove=true", causing the command "sudo yum remove pulp-\* python-pulp\*" to not only remove those packages, but also their installed dependencies.

The solution proposed in irc is to switch the documentation to specify installing the required packages based on the .spec file, as used in the vagrant-setup.sh script.

https://github.com/pulp/pulp/blob/master/playpen/vagrant-setup.sh#L24

Actions #1

Updated by mhrivnak about 7 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to dkliban@redhat.com
  • Triaged changed from No to Yes
  • Tags Documentation added

Added by dkliban@redhat.com about 7 years ago

Revision 81adc200

Updates dev-guide with dnf commands

https://pulp.plan.io/issues/1277 closes #1277

Added by dkliban@redhat.com about 7 years ago

Revision 81adc200

Updates dev-guide with dnf commands

https://pulp.plan.io/issues/1277 closes #1277

Actions #2

Updated by dkliban@redhat.com about 7 years ago

  • Status changed from ASSIGNED to MODIFIED
  • % Done changed from 0 to 100
Actions #3

Updated by dkliban@redhat.com about 7 years ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE
  • Platform Release set to 2.6.4
Actions #4

Updated by bmbouter over 3 years ago

  • Tags Pulp 2 added
Actions #5

Updated by bmbouter over 2 years ago

  • Category deleted (23)

Also available in: Atom PDF