Project

Profile

Help

Issue #1100

repo bind failing on consumer

Added by pthomas@redhat.com over 6 years ago. Updated about 1 year ago.

Status:
CLOSED - WORKSFORME
Priority:
High
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.7.0 Beta
Platform Release:
2.7.0
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Repo bind seems to be failing on consumer

Binding a repo to the consumer seems to be failing.

[root@qe-blade-10 ~]# rpm -qa pulp-server
pulp-server-2.7.0-0.3.beta.el6.noarch
[root@qe-blade-10 ~]# 
[root@qe-blade-10 ~]# pulp-admin rpm consumer bind --repo-id pulp --consumer-id 1234
An internal error occurred on the Pulp server:

RequestException: POST request
on /pulp/api/v2/consumers/1234/bindings/ failed with 500 - 'TaskStatus' object
has no attribute 'to_json'
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: Unhandled Exception
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496) 'TaskStatus' object has no attribute 'to_json'
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496) Traceback (most recent call last):
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/django/core/handlers/base.py", line 109, in get_response
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     response = callback(request, *callback_args, **callback_kwargs)
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/django/views/generic/base.py", line 48, in view
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     return self.dispatch(request, *args, **kwargs)
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/django/views/generic/base.py", line 69, in dispatch
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     return handler(request, *args, **kwargs)
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/views/decorators.py", line 237, in _auth_decorator
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     return _verify_auth(self, operation, super_user_only, method, *args, **kwargs)
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/views/decorators.py", line 191, in _verify_auth
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     value = method(self, *args, **kwargs)
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/views/util.py", line 110, in wrapper
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     return func(*args, **kwargs)
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/views/consumers.py", line 415, in post
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     consumer_id, repo_id, distributor_id, notify_agent, binding_config, options)
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/pulp/server/tasks/consumer.py", line 39, in bind
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     task = agent_manager.bind(consumer_id, repo_id, distributor_id, agent_options)
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/pulp/server/managers/consumer/agent.py", line 88, in bind
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     task = TaskStatus(task_id, 'agent', tags=task_tags).save()
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/mongoengine/document.py", line 274, in save
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     signals.post_save.send(self.__class__, document=self, created=created)
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/blinker/base.py", line 220, in send
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     for receiver in self.receivers_for(sender)]
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/pulp/server/db/model/__init__.py", line 311, in post_save
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     send_taskstatus_message(document, routing_key="tasks.%%s" %% document['task_id'])
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)   File "/usr/lib/python2.6/site-packages/pulp/server/async/emit.py", line 29, in send
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496)     payload = document.to_json()
Jul  1 17:21:16 qe-blade-10 pulp: pulp.server.webservices.middleware.exception:ERROR: (6190-06496) AttributeError: 'TaskStatus' object has no attribute 'to_json'

History

#1 Updated by mhrivnak over 6 years ago

  • Priority changed from Normal to High
  • Version set to 2.7.0 Beta
  • Platform Release set to 2.7.0
  • Triaged changed from No to Yes

#2 Updated by ipanova@redhat.com over 6 years ago

Was not able to reproduce this:

  1. pulp-admin rpm consumer bind --repo-id zoo --consumer-id c1
    This command may be exited via ctrl+c without affecting the request.

[\]
Running...

Task Succeeded

[root@ec2-54-170-75-199 ~]# rpm -qa pulp-server
pulp-server-2.7.0-0.3.beta.fc20.noarch

#3 Updated by dkliban@redhat.com over 6 years ago

My guess is that an older version of mongoengine was installed when this error was encountered. We now carry mongoengine 0.9.0.

#4 Updated by amacdona@redhat.com about 6 years ago

  • Status changed from NEW to CLOSED - WORKSFORME

wrote:

My guess is that an older version of mongoengine was installed when this error was encountered. We now carry mongoengine 0.9.0.

I agree. Closing, please reopen if this is still an issue.

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF