Project

Profile

Help

Issue #1001

httpd pulp.conf: use IncludeOptional instead of Include

Added by igulina@redhat.com over 6 years ago. Updated over 2 years ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
2.6.0
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Easy Fix, Pulp 2
Sprint:
Quarter:

Description

pulp 2.6.0.2 on rhel7

Can't start httpd

>> journalctl -nx
httpd: Syntax error on line 353 of /etc/httpd/conf/httpd.conf: Syntax error on line 54 of /etc/httpd/conf.d/pulp.conf: No matches for the w
May 26 10:50:50 XXX systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
May 26 10:50:50 XXX kill[4875]: kill: cannot find process "" 
May 26 10:50:50 XXX systemd[1]: httpd.service: control process exited, code=exited status=1
May 26 10:50:50 XXX: Failed to start The Apache HTTP Server.

>> vi /etc/httpd/conf.d/pulp.conf
<VirtualHost *:80>
    Include /etc/pulp/vhosts80/*.conf
</VirtualHost>

Changing line#54 Inclide/IncludeOptional in /etc/httpd/conf.d/pulp.conf fixes the issue.

>>vi /etc/httpd/conf.d/pulp.conf
<VirtualHost *:80>
    IncludeOptional /etc/pulp/vhosts80/*.conf
</VirtualHost>

>> systemctl restart httpd
>> pulp-admin login -u admin -p admin 
Successfully logged in. Session certificate will expire at Jun  2 15:02:43 2015
GMT.

Related issues

Has duplicate Pulp - Issue #819: httpd will not start if plugins do not put at least one file in /etc/pulp/vhosts80/CLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Issue #293: Apache Complains On Missing Pulp ModulesCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mhrivnak over 6 years ago

  • Version set to 2.6.0
  • Triaged changed from No to Yes
  • Tags Easy Fix added

Thanks for the suggested solution!

#2 Updated by mhrivnak over 6 years ago

  • Has duplicate Issue #819: httpd will not start if plugins do not put at least one file in /etc/pulp/vhosts80/ added

#3 Updated by mhrivnak over 6 years ago

  • Is duplicate of Issue #293: Apache Complains On Missing Pulp Modules added

#4 Updated by mhrivnak over 6 years ago

  • Status changed from NEW to CLOSED - DUPLICATE

#5 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF