Project

Profile

Help

Issue #992

Missing Dependency: python-saslwrapper >= 0.10 is needed by package python-qpid-0.18-10.el5.noarch

Added by rbarlow over 6 years ago. Updated about 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
High
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
2.4.4
Platform Release:
2.6.4
OS:
RHEL 5
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Pulp 2
Sprint:
Quarter:

Description

Pulp 2.4 and 2.6 cannot be installed from our community repository currently, due to a dependency error. The error message is "Missing Dependency: python-saslwrapper >= 0.10 is needed by package python-qpid-0.18-10.el5.noarch". Here is the full output:

# yum groupinstall pulp-consumer-qpidLoaded plugins: product-id, rhnplugin, security, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
https://repos.fedorapeople.org/repos/pulp/pulp/beta/2.6/5Client/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Setting up Group Process
Failed to add groups file for repository: epel - comps file is empty/damaged
Resolving Dependencies
--> Running transaction check
---> Package pulp-agent.noarch 0:2.6.2-0.2.beta.el5 set to be updated
--> Processing Dependency: python-pulp-bindings = 2.6.2 for package: pulp-agent
--> Processing Dependency: python-pulp-agent-lib = 2.6.2 for package: pulp-agent
--> Processing Dependency: python-gofer >= 2.5 for package: pulp-agent
--> Processing Dependency: gofer >= 2.5 for package: pulp-agent
---> Package pulp-consumer-client.noarch 0:2.6.2-0.2.beta.el5 set to be updated
--> Processing Dependency: python-pulp-common = 2.6.2 for package: pulp-consumer-client
--> Processing Dependency: python-pulp-client-lib = 2.6.2 for package: pulp-consumer-client
---> Package pulp-puppet-consumer-extensions.noarch 0:2.6.2-0.2.beta.el5 set to be updated
--> Processing Dependency: python-pulp-puppet-common = 2.6.2 for package: pulp-puppet-consumer-extensions
---> Package pulp-puppet-handlers.noarch 0:2.6.2-0.2.beta.el5 set to be updated
--> Processing Dependency: puppet >= 2.7.14 for package: pulp-puppet-handlers
---> Package pulp-rpm-consumer-extensions.noarch 0:2.6.2-0.2.beta.el5 set to be updated
---> Package pulp-rpm-handlers.noarch 0:2.6.2-0.2.beta.el5 set to be updated
--> Processing Dependency: python-pulp-rpm-common = 2.6.2 for package: pulp-rpm-handlers
---> Package pulp-rpm-yumplugins.noarch 0:2.6.2-0.2.beta.el5 set to be updated
---> Package python-gofer-qpid.noarch 0:2.6.1-1.el5 set to be updated
--> Processing Dependency: python-qpid >= 0.18 for package: python-gofer-qpid
--> Processing Dependency: python-ssl for package: python-gofer-qpid
--> Running transaction check
---> Package gofer.noarch 0:2.6.1-1.el5 set to be updated
---> Package puppet.noarch 0:2.7.25-1.el5 set to be updated
--> Processing Dependency: facter < 1:2.0 for package: puppet
--> Processing Dependency: ruby(abi) >= 1.8 for package: puppet
--> Processing Dependency: ruby >= 1.8.5 for package: puppet
--> Processing Dependency: facter >= 1.5 for package: puppet
--> Processing Dependency: ruby-shadow for package: puppet
--> Processing Dependency: ruby-augeas for package: puppet
--> Processing Dependency: libselinux-ruby for package: puppet
--> Processing Dependency: /usr/bin/ruby for package: puppet
---> Package python-gofer.noarch 0:2.6.1-1.el5 set to be updated
--> Processing Dependency: python-hashlib for package: python-gofer
--> Processing Dependency: python-ctypes for package: python-gofer
---> Package python-pulp-agent-lib.noarch 0:2.6.2-0.2.beta.el5 set to be updated
---> Package python-pulp-bindings.noarch 0:2.6.2-0.2.beta.el5 set to be updated
---> Package python-pulp-client-lib.noarch 0:2.6.2-0.2.beta.el5 set to be updated
--> Processing Dependency: python-okaara >= 1.0.32 for package: python-pulp-client-lib
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: python-pulp-client-lib
---> Package python-pulp-common.noarch 0:2.6.2-0.2.beta.el5 set to be updated
---> Package python-pulp-puppet-common.noarch 0:2.6.2-0.2.beta.el5 set to be updated
---> Package python-pulp-rpm-common.noarch 0:2.6.2-0.2.beta.el5 set to be updated
---> Package python-qpid.noarch 0:0.18-10.el5 set to be updated
--> Processing Dependency: python-saslwrapper >= 0.10 for package: python-qpid
---> Package python-ssl.x86_64 0:1.15-3.el5 set to be updated
--> Running transaction check
---> Package facter.x86_64 0:1.6.18-3.el5 set to be updated
---> Package libselinux-ruby.x86_64 0:1.33.4-5.7.el5 set to be updated
---> Package python-ctypes.x86_64 0:1.0.2-3.el5 set to be updated
---> Package python-hashlib.x86_64 0:20081119-4.el5 set to be updated
---> Package python-isodate.noarch 0:0.5.0-4.pulp.el5 set to be updated
---> Package python-okaara.noarch 0:1.0.35-1.el5 set to be updated
---> Package python-qpid.noarch 0:0.18-10.el5 set to be updated
--> Processing Dependency: python-saslwrapper >= 0.10 for package: python-qpid
---> Package ruby.x86_64 0:1.8.5-31.el5_9 set to be updated
---> Package ruby-augeas.x86_64 0:0.4.1-1.el5 set to be updated
--> Processing Dependency: augeas-libs >= 0.8.0 for package: ruby-augeas
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.8.0)(64bit) for package: ruby-augeas
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.12.0)(64bit) for package: ruby-augeas
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.11.0)(64bit) for package: ruby-augeas
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.10.0)(64bit) for package: ruby-augeas
--> Processing Dependency: libaugeas.so.0(AUGEAS_0.1.0)(64bit) for package: ruby-augeas
--> Processing Dependency: libaugeas.so.0()(64bit) for package: ruby-augeas
---> Package ruby-libs.x86_64 0:1.8.5-31.el5_9 set to be updated
---> Package ruby-shadow.x86_64 0:1.4.1-7.el5 set to be updated
--> Running transaction check
---> Package augeas-libs.x86_64 0:1.2.0-1.el5 set to be updated
---> Package python-qpid.noarch 0:0.18-10.el5 set to be updated
--> Processing Dependency: python-saslwrapper >= 0.10 for package: python-qpid
--> Finished Dependency Resolution
python-qpid-0.18-10.el5.noarch from pulp-2.6-beta has depsolving problems
  --> Missing Dependency: python-saslwrapper >= 0.10 is needed by package python-qpid-0.18-10.el5.noarch (pulp-2.6-beta)
Error: Missing Dependency: python-saslwrapper >= 0.10 is needed by package python-qpid-0.18-10.el5.noarch (pulp-2.6-beta)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

This likely affects CentOS 5 as well, though I have not tested it.

History

#1 Updated by rbarlow over 6 years ago

It appears that python-saslwrapper is no longer available for RHEL 5:

$ yum info python-saslwrapper
Loaded plugins: product-id, pulp-profile-update, security,
subscription-manager
Error: No matching Packages to list

--
Randy Barlow

#2 Updated by bmbouter over 6 years ago

The necessary dependency is already built on koji.katello.org [0]. I think all we need to do is specify that saslwrapper 0.10-8 be included for EL5 in external_deps.json [1].

[0]: http://koji.katello.org/koji/buildinfo?buildID=8174
[1]: https://github.com/pulp/pulp/blob/fc772469bf05797aadec53f8be52e27810291705/deps/external_deps.json

#3 Updated by mhrivnak over 6 years ago

  • Priority changed from Normal to High
  • Severity changed from 2. Medium to 3. High
  • Triaged changed from No to Yes

#4 Updated by ipanova@redhat.com about 6 years ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com

#5 Updated by ipanova@redhat.com about 6 years ago

  • Status changed from ASSIGNED to POST

#6 Updated by ipanova@redhat.com about 6 years ago

  • Status changed from POST to MODIFIED

#7 Updated by ipanova@redhat.com about 6 years ago

  • Platform Release set to 2.6.4

#8 Updated by ipanova@redhat.com about 6 years ago

  • Status changed from MODIFIED to 5

#9 Updated by ipanova@redhat.com about 6 years ago

  • Status changed from 5 to CLOSED - CURRENTRELEASE

#10 Updated by bmbouter over 2 years ago

  • Tags Pulp 2 added

Please register to edit this issue

Also available in: Atom PDF