Project

Profile

Help

Issue #9608

closed

Deprecation warning in Roles doesn't include enough info

Added by bmbouter about 1 year ago. Updated 12 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 111
Quarter:

Description

When running pclean (or a user at upgrade time) on pulp:main would see this warning:

pulp [None]: pulpcore.deprecation:WARNING: The 'permissions' field in 'creation_hooks' is deprecated and may be removed with pulpcore 3.20. Use the 'parameters' field instead.

This is telling us that we haven't ported the AcessPolicy for ContentGuard, except that it doesn't indicate that it's about ContentGuard. These messages should be improved.

Actions #1

Updated by pulpbot about 1 year ago

  • Status changed from ASSIGNED to POST

Added by bmbouter 12 months ago

Revision 7f4d623c

Adds viewset name to accesspolicy deprecations

The deprecation warning about an offending AccessPolicy now includes the name of the Viewset that has the problem.

closes #9608

Actions #2

Updated by bmbouter 12 months ago

  • Status changed from POST to MODIFIED
Actions #3

Updated by pulpbot 12 months ago

  • Sprint/Milestone set to 3.17.0
Actions #4

Updated by pulpbot 12 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF