Project

Profile

Help

Issue #9417

closed

Story #7832: [EPIC] As a user, I have Alternate Content Sources

ACS content isn't cleaned up with orphan removal

Added by daviddavis about 1 year ago. Updated 12 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 105
Quarter:

Description

Steps to reproduce:

  1. Create an ACS and refresh it
  2. Observe the new content units
  3. Remove the ACS
  4. Run orphan cleanup
  5. Observe that ACS's content is still present

This is because the ACS repos aren't cleaned up when the ACS is deleted. We have a many-to-many relationship between ACS and repos and cascade deletion doesn't work.

I think we should probably add a hook on ACS delete to delete the repos as well.

Actions #1

Updated by ipanova@redhat.com about 1 year ago

  • Status changed from NEW to ASSIGNED
  • Assignee set to ipanova@redhat.com
  • Sprint set to Sprint 105
Actions #2

Updated by ipanova@redhat.com about 1 year ago

  • Parent task set to #7832
Actions #3

Updated by pulpbot about 1 year ago

  • Status changed from ASSIGNED to POST

Added by ipanova@redhat.com about 1 year ago

Revision 20f6520a

Ensured that with the removal of ACS it's hidden repositories are removed as well.

closes #9417 closes #9374

Actions #4

Updated by ipanova@redhat.com about 1 year ago

  • Status changed from POST to MODIFIED
Actions #5

Updated by pulpbot 12 months ago

  • Sprint/Milestone set to 3.16.0
Actions #6

Updated by pulpbot 12 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF