Project

Profile

Help

Issue #9369

After cancelling a task, some progress reports still say "running"

Added by iballou about 1 month ago. Updated about 1 month ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
-
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Example:

{
  "pulp_href": "/pulp/api/v3/tasks/68212e14-1c59-475c-ad2a-3d0caef9ce48/",
  "pulp_created": "2021-09-09T19:34:03.474566Z",
  "state": "canceled",
  "name": "pulp_2to3_migration.app.tasks.migrate.migrate_from_pulp2",
  "started_at": "2021-09-09T19:34:03.590782Z",
  "finished_at": null,
  "error": null,
  "worker": "/pulp/api/v3/workers/0559b798-e80c-4c56-b123-7115626645a1/",
  "parent_task": null,
  "child_tasks": [],
  "task_group": "/pulp/api/v3/task-groups/2e20794d-40da-4c0a-9c5f-09816d21c344/",
  "progress_reports": [
    {
      "message": "Processing Pulp 2 repositories, importers, distributors",
      "code": "processing.repositories",
      "state": "completed",
      "total": 4,
      "done": 4,
      "suffix": null
    },
    {
      "message": "Pre-migrating Pulp 2 deb content (general info)",
      "code": "premigrating.content.general",
      "state": "completed",
      "total": 0,
      "done": 0,
      "suffix": null
    },
    {
      "message": "Pre-migrating Pulp 2 deb content (detail info)",
      "code": "premigrating.content.detail",
      "state": "completed",
      "total": 0,
      "done": 0,
      "suffix": null
    },
    {
      "message": "Pre-migrating Pulp 2 deb_release content (general info)",
      "code": "premigrating.content.general",
      "state": "completed",
      "total": 0,
      "done": 0,
      "suffix": null
    },
    {
      "message": "Pre-migrating Pulp 2 deb_release content (detail info)",
      "code": "premigrating.content.detail",
      "state": "completed",
      "total": 0,
      "done": 0,
      "suffix": null
    },
    {
      "message": "Pre-migrating Pulp 2 deb_component content (general info)",
      "code": "premigrating.content.general",
      "state": "completed",
      "total": 0,
      "done": 0,
      "suffix": null
    },
    {
      "message": "Pre-migrating Pulp 2 deb_component content (detail info)",
      "code": "premigrating.content.detail",
      "state": "completed",
      "total": 0,
      "done": 0,
      "suffix": null
    },
    {
      "message": "Pre-migrating Pulp 2 iso content (general info)",
      "code": "premigrating.content.general",
      "state": "completed",
      "total": 0,
      "done": 0,
      "suffix": null
    },
    {
      "message": "Pre-migrating Pulp 2 iso content (detail info)",
      "code": "premigrating.content.detail",
      "state": "completed",
      "total": 0,
      "done": 0,
      "suffix": null
    },
    {
      "message": "Pre-migrating Pulp 2 rpm content (detail info)",
      "code": "premigrating.content.detail",
      "state": "running",                                   <==================================================
      "total": 13723,
      "done": 11000,
      "suffix": null
    },
    {
      "message": "Pre-migrating Pulp 2 rpm content (general info)",
      "code": "premigrating.content.general",
      "state": "running",                                 <==================================================
      "total": 13723,
      "done": 12000,
      "suffix": null
    }
  ],
  "created_resources": [
    "/pulp/api/v3/task-groups/2e20794d-40da-4c0a-9c5f-09816d21c344/"
  ],
  "reserved_resources_record": [
    "pulp_2to3_migration"
  ]
}

Pulp versions:

pulp-2to3-migration (0.11.1)
pulp-certguard (1.0.3)
pulp-cli (0.10.1)
pulp-container (2.1.2)
pulp-deb (2.9.2)
pulp-file (1.3.0)
pulp-rpm (3.10.0)

pulpcore (3.7.6)


Related issues

Is duplicate of Pulp - Issue #4921: canceled tasks have progress reports in not final statesCLOSED - CURRENTRELEASE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by dkliban@redhat.com about 1 month ago

  • Is duplicate of Issue #4921: canceled tasks have progress reports in not final states added

#2 Updated by dkliban@redhat.com about 1 month ago

  • Status changed from NEW to CLOSED - DUPLICATE

This was fixed in 3.8. Please file a backport request if the fix is needed in 3.7.

Please register to edit this issue

Also available in: Atom PDF