Project

Profile

Help

Issue #9238

closed

Depsolving in multi-arch context isn't correct

Added by ggainey 9 months ago. Updated 9 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
Yes
Groomed:
No
Sprint Candidate:
No
Tags:
Katello
Sprint:
Sprint 103
Quarter:

Description

Sync RHEL7. Create a new repository. Pick (for example) "all RPMs not referenced by an advisory". Hand that list to an advanced-copy confi with depsolving=True. Watch the log fill with entries like this:

Aug 12 15:23:57 pulp2-nightly-pulp3-source-centos7.padre-fedora.example.com pulpcore-worker[3881]: pulp [a8dbf93f57d744daac03334a10415e76]: pulp_rpm.app.depsolving:WARNING: Encountered problems solving dependencies, copy may be incomplete: package isdn4k-utils-0:3.2-95.el7.i686 requires libc.so.6, but none of the providers can be installed

Related issues

Copied to RPM Support - Backport #9293: Backport #9238 "Depsolving in multi-arch context isn't correct" to 3.14.zCLOSED - CURRENTRELEASE

Actions
Actions #1

Updated by pulpbot 9 months ago

  • Status changed from ASSIGNED to POST
Actions #2

Updated by dalley 9 months ago

  • Triaged changed from No to Yes

Added by ggainey 9 months ago

Revision 0970c65f

Taught depsolving to handle multiarch and multiversions better.

fixes #9238. [nocoverage]

Actions #3

Updated by ggainey 9 months ago

  • Status changed from POST to MODIFIED
Actions #4

Updated by dalley 9 months ago

  • Sprint/Milestone set to 3.15.0
Actions #5

Updated by dalley 9 months ago

  • Copied to Backport #9293: Backport #9238 "Depsolving in multi-arch context isn't correct" to 3.14.z added
Actions #7

Updated by pulpbot 9 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF