Project

Profile

Help

Issue #9180

pulp-installer CI doesn't properly test upgrading RPM packages

Added by mdepaulo@redhat.com about 2 months ago. Updated about 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
CI/CD
Sprint:
Quarter:

Description

The task pulp_common : Add pulpcore RPM repositories doesn't replace the old repo URL when users specify a new one pulp_pkg_repo. This should be properly fixed, but this bug is written for a CI workaround.

The katello repo had "latest" in its URL, but the foreman repos have pulpcore minor releases like "3.6" in their URL. This triggers the problem when a user upgrades, or the CI upgrades.


Related issues

Related to Pulp - Issue #9182: pulp_installer should support replacing the RPM repo URLCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Issue #8586: Installer is failing when upgrade pulpcore packageMODIFIED<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by pulpbot about 2 months ago

  • Status changed from NEW to POST

#2 Updated by mdepaulo@redhat.com about 2 months ago

  • Related to Issue #9182: pulp_installer should support replacing the RPM repo URL added

#3 Updated by mdepaulo@redhat.com about 2 months ago

  • Status changed from POST to CLOSED - DUPLICATE

Actually this is performed by #8586, even on the 3.7 branch.

Maybe I was confused by the fact that the molecule prepare.yml on that branch needed it.

#4 Updated by mdepaulo@redhat.com about 2 months ago

  • Is duplicate of Issue #8568: Overall task status remains in 'running' state while all the reports are in the final state added

#5 Updated by mdepaulo@redhat.com about 2 months ago

  • Is duplicate of deleted (Issue #8568: Overall task status remains in 'running' state while all the reports are in the final state)

#6 Updated by mdepaulo@redhat.com about 2 months ago

  • Is duplicate of Issue #8586: Installer is failing when upgrade pulpcore package added

#7 Updated by dalley about 2 months ago

  • Sprint/Milestone deleted (3.14.4)

Dropping from the release since it's a dup.

Please register to edit this issue

Also available in: Atom PDF