Project

Profile

Help

Issue #9182

pulp_installer should support replacing the RPM repo URL

Added by mdepaulo@redhat.com about 2 months ago. Updated about 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

When a user specifies the 3rd party repo in pulp_pkg_repo, like "pulp_pkg_repo: https://yum.theforeman.org/pulpcore/3.11/el8/x86_64/`, changing the URL during a subsequent ansible run has no effect on the system.

If the user were to change part of the URL from "3.11" to "3.14" (to upgrade pulpcore from 3.11 to 3.14), nothing would happen to the URL on disk in /etc/yum.repos.d/pulpcore (or to the actually installed version of pulpcore.)

Our CI works around this in #9180. We can revert that change to molecule prepare.yml once this is fixed.


Related issues

Related to Pulp - Issue #9180: pulp-installer CI doesn't properly test upgrading RPM packagesCLOSED - DUPLICATE<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Related to Pulp - Issue #8586: Installer is failing when upgrade pulpcore packageMODIFIED<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>
Is duplicate of Pulp - Issue #8586: Installer is failing when upgrade pulpcore packageMODIFIED<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by mdepaulo@redhat.com about 2 months ago

  • Related to Issue #9180: pulp-installer CI doesn't properly test upgrading RPM packages added

#2 Updated by mdepaulo@redhat.com about 2 months ago

I was mistaken, this was already fixed part of #8586

#3 Updated by mdepaulo@redhat.com about 2 months ago

  • Related to Issue #8586: Installer is failing when upgrade pulpcore package added

#4 Updated by mdepaulo@redhat.com about 2 months ago

  • Is duplicate of Issue #8586: Installer is failing when upgrade pulpcore package added

#5 Updated by mdepaulo@redhat.com about 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

Please register to edit this issue

Also available in: Atom PDF