Project

Profile

Help

Issue #9164

Dropping Python 3.6 and 3.7 from the 2.14 release branch was a mistake

Added by quba42 about 2 months ago. Updated about 2 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Urgent
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version - Debian:
Platform Release:
Target Release - Debian:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

It looks like this was merged prematurely on my part.

Users have reported the following:

I tried to update pulp_deb plugins using ansible but getting error as per below.

TASK [pulp.pulp_installer.pulp_common : Install prerequisites] ******************************************************************************************************************************************************************************
fatal: [pulptest008.karmalab.net]: FAILED! => {"changed": false, "msg": "No package matching 'rh-python38-python' found available, installed or updated", "rc": 126, "results": ["python-setuptools-0.9.8-7.el7.noarch providing python-setuptools is already installed", "No package matching 'rh-python38-python' found available, installed or updated"]}

Fresh installs are also suffering weird dependency effects where Python 3 is not being installed at all.

Associated revisions

Revision 2553e2e5 View on GitHub
Added by quba42 about 2 months ago

Re-enable Python 3.6 and 3.7 for 2.14 branch

Closes #9164 https://pulp.plan.io/issues/9164

History

#1 Updated by pulpbot about 2 months ago

  • Status changed from NEW to POST

#2 Updated by quba42 about 2 months ago

  • Status changed from POST to MODIFIED

#3 Updated by pulpbot about 2 months ago

  • Sprint/Milestone set to 2.14.1

#4 Updated by pulpbot about 2 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF