Project

Profile

Help

Issue #9139

pulp_installer fails when symlinking webserver snippets

Added by mdepaulo@redhat.com 2 months ago. Updated about 2 months ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Category:
Installer
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 101
Quarter:

Description

This appears to be because our check_snippet.py script sometimes produces the following output: "stdout_lines": ["/home/vagrant/devel/pulp_python/pulp_python/app/webserver_snippets/nginx.conf", "\u001b[0m"]

The 2nd line appears to be a color code: https://gist.github.com/mgumiero9/665ab5f0e5e7e46cb049c1544a00e29f

It does not happen all the time, I think it is system-configuration dependent (environment variables for colored output?)

Associated revisions

Revision f6cb70ea View on GitHub
Added by Mike DePaulo 2 months ago

Fix pulp_installer failing to symlink snippets

By operating on the 1st line of output from check_snippet.py, rather than the last.

fixes: #9139

Revision f6cb70ea View on GitHub
Added by Mike DePaulo 2 months ago

Fix pulp_installer failing to symlink snippets

By operating on the 1st line of output from check_snippet.py, rather than the last.

fixes: #9139

History

#1 Updated by mdepaulo@redhat.com 2 months ago

  • Subject changed from pulp_installer fails when symlinking webserver snippets on certian systems to pulp_installer fails when symlinking webserver snippets

#2 Updated by mdepaulo@redhat.com 2 months ago

  • Description updated (diff)

#3 Updated by pulpbot 2 months ago

  • Status changed from NEW to POST

#4 Updated by Anonymous 2 months ago

  • Status changed from POST to MODIFIED

#5 Updated by fao89 about 2 months ago

  • Sprint/Milestone set to 3.14.3-1

#6 Updated by pulpbot about 2 months ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Please register to edit this issue

Also available in: Atom PDF