Project

Profile

Help

Issue #9080

closed

Invalid relative URLs are not identified beforehand

Added by lmjachky over 1 year ago. Updated over 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
Category:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Version:
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Sprint 100
Quarter:

Description

The problem is that file:// is a part of the URL, so the actual path is interpreted as relative (home/vagrant/...) instead of absolute (/home/vagrant/...). That feels like something that we could be catching upfront.

Solution:

Reject all relative paths with a specific error message.


Related issues

Copied to Pulp - Backport #9083: Backport 9080 "Invalid relative URLs are not identified beforehand" to 3.14.zCLOSED - CURRENTRELEASEmdellweg

Actions

Also available in: Atom PDF