Project

Profile

Help

Issue #8963

deadlock when synching Foreman proxy

Added by jlhm 3 months ago. Updated about 2 months ago.

Status:
CLOSED - DUPLICATE
Priority:
Normal
Assignee:
-
Category:
Installer
Sprint/Milestone:
-
Start date:
Due date:
Estimated time:
Severity:
3. High
Version:
Platform Release:
OS:
CentOS 7
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Getting deadlock error when synching rpm repos to a Foreman 2.5.0 proxy.

2021-06-23T16:32:03 [E|bac|4455b9dd] deadlock detected
 4455b9dd | DETAIL:  Process 15832 waits for ShareLock on transaction 586192; blocked by process 15825.
 4455b9dd | Process 15825 waits for ShareLock on transaction 586194; blocked by process 15832.
 4455b9dd | HINT:  See server log for query details.
 4455b9dd | CONTEXT:  while inserting index tuple (39147,3) in relation "rpm_package_pkgId_key"
 4455b9dd |  (Katello::Errors::Pulp3Error)
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-4.1.0/app/lib/actions/pulp3/abstract_async_task.rb:102:in `block in check_for_errors'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-4.1.0/app/lib/actions/pulp3/abstract_async_task.rb:100:in `each'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-4.1.0/app/lib/actions/pulp3/abstract_async_task.rb:100:in `check_for_errors'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-4.1.0/app/lib/actions/pulp3/abstract_async_task.rb:133:in `poll_external_task'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-1.4.8/lib/dynflow/action/polling.rb:100:in `poll_external_task_with_rescue'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-1.4.8/lib/dynflow/action/polling.rb:22:in `run'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-1.4.8/lib/dynflow/action/cancellable.rb:14:in `run'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-4.1.0/app/lib/actions/pulp3/abstract_async_task.rb:10:in `run'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-1.4.8/lib/dynflow/action.rb:571:in `block (3 levels) in execute_run'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-1.4.8/lib/dynflow/middleware/stack.rb:27:in `pass'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-1.4.8/lib/dynflow/middleware.rb:19:in `pass'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/katello-4.1.0/app/lib/actions/middleware/record_smart_proxy_sync_history.rb:26:in `run'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-1.4.8/lib/dynflow/middleware/stack.rb:23:in `call'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-1.4.8/lib/dynflow/middleware/stack.rb:27:in `pass'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-1.4.8/lib/dynflow/middleware.rb:19:in `pass'
 4455b9dd | /opt/theforeman/tfm/root/usr/share/gems/gems/dynflow-1.4.8/lib/dynflow/middleware.rb:32:in `run'
deadlock.txt (2.64 KB) deadlock.txt log file jlhm, 06/23/2021 11:50 PM

Related issues

Is duplicate of Pulp - Issue #8750: Deadlock on rpm repository pulp2pulp syncASSIGNED<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by jlhm 3 months ago

#2 Updated by ttereshc 3 months ago

  • Description updated (diff)

#3 Updated by dalley about 2 months ago

  • Related to Issue #8750: Deadlock on rpm repository pulp2pulp sync added

#4 Updated by dalley about 2 months ago

  • Status changed from NEW to CLOSED - DUPLICATE

#5 Updated by dalley about 2 months ago

  • Related to deleted (Issue #8750: Deadlock on rpm repository pulp2pulp sync)

#6 Updated by dalley about 2 months ago

  • Is duplicate of Issue #8750: Deadlock on rpm repository pulp2pulp sync added

Please register to edit this issue

Also available in: Atom PDF