Project

Profile

Help

Task #8854

Task #8853: [EPIC] Drop support for Python 3.6

Indicate the installer no longer supports EL7

Added by bmbouter 6 months ago. Updated 4 months ago.

Status:
CLOSED - WONTFIX
Priority:
Normal
Assignee:
-
Category:
Installer - Moved to GitHub issues
Sprint/Milestone:
Start date:
Due date:
% Done:

0%

Estimated time:
Platform Release:
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

History

#1 Updated by bmbouter 6 months ago

  • Subject changed from Add installer support (if necessary) for the when the EL7 katello rpms switch to SCLs to Indicate the installer no longer supports EL7
  • Sprint/Milestone set to 3.15.0

See this comment. The desire of the pulpcore team from today's meeting is to recommend users either configure SCL's themselves outside of the installer, or to upgrade to EL8 for Pulp. This means that with 3.15 the installer can formally only claim EL8 support.

#2 Updated by daviddavis 6 months ago

FYI, @jsherrill brought up this point about the init scripts: https://github.com/pulp/community/discussions/3#discussioncomment-841903

#3 Updated by daviddavis 4 months ago

  • Status changed from NEW to CLOSED - WONTFIX

Closing since support for Python 3.8 on EL7 systems was added in https://github.com/pulp/pulp_installer/pull/650.

Please register to edit this issue

Also available in: Atom PDF