Project

Profile

Help

Issue #8612

closed

The deb migration pipeline cannot successfully skip corrupted content

Added by quba42 over 1 year ago. Updated about 1 year ago.

Status:
CLOSED - CURRENTRELEASE
Priority:
Normal
Assignee:
-
Sprint/Milestone:
Start date:
Due date:
Estimated time:
Severity:
2. Medium
Platform Release:
OS:
Triaged:
No
Groomed:
No
Sprint Candidate:
No
Tags:
Sprint:
Quarter:

Description

Running a 2ot3 migration for deb content with skip_corrupted=True will result in the following error (if there actually is corrupted content):

pulp_deb.app.models.content.PackageReleaseComponent.package.RelatedObjectDoesNotExist: PackageReleaseComponent has no package.

This is because the PackageReleaseComponent still tries to record a relation to the skipped package.

This is a possible duplicate of: https://pulp.plan.io/issues/8562 (the different manifestations could be a result of different pulpcore versions, or it is a completely unrelated issue).

Added by quba42 over 1 year ago

Revision 1ad1be59

Skip PackageReleaseComponents if Package was skipped

fixes #8612 https://pulp.plan.io/issues/8612

Added by quba42 over 1 year ago

Revision 1ad1be59

Skip PackageReleaseComponents if Package was skipped

fixes #8612 https://pulp.plan.io/issues/8612

Added by quba42 over 1 year ago

Revision 1ad1be59

Skip PackageReleaseComponents if Package was skipped

fixes #8612 https://pulp.plan.io/issues/8612

Actions #1

Updated by quba42 over 1 year ago

  • Status changed from NEW to MODIFIED
Actions #2

Updated by ttereshc over 1 year ago

  • Sprint/Milestone set to 0.11.1

Added by quba42 over 1 year ago

Revision 1988dd6e

Skip PackageReleaseComponents if Package was skipped

fixes #8612 https://pulp.plan.io/issues/8612

(cherry picked from commit 1ad1be59ddfa43d11eb7e9a26c62004ade5f3d6d)

Added by quba42 over 1 year ago

Revision 1988dd6e

Skip PackageReleaseComponents if Package was skipped

fixes #8612 https://pulp.plan.io/issues/8612

(cherry picked from commit 1ad1be59ddfa43d11eb7e9a26c62004ade5f3d6d)

Added by quba42 over 1 year ago

Revision 1988dd6e

Skip PackageReleaseComponents if Package was skipped

fixes #8612 https://pulp.plan.io/issues/8612

(cherry picked from commit 1ad1be59ddfa43d11eb7e9a26c62004ade5f3d6d)

Actions #3

Updated by pulpbot over 1 year ago

  • Status changed from MODIFIED to CLOSED - CURRENTRELEASE

Also available in: Atom PDF